Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Host changed DNS - now I can't upload assets


Reply


4 Posts   1384 Views

Avatar
Gina

Community Member, 11 Posts

13 March 2010 at 4:56am

Hi - Not sure this is the correct place to ask this question. My site us up and working but my host changed their DNS and I have no earthly idea where I tell SS to use the new credentials to ftp files. I can't upload any assets and get an error when I try. It appears this is also affecting form submittals on the server. I did not originally install SS - a developer did this and he has abandoned me. If there is a file I can change to update this please tell me where to locate it. THANKS IN ADVANCE! :o(

Avatar
Sean

Forum Moderator, 922 Posts

14 March 2010 at 1:19pm

Edited: 14/03/2010 1:21pm

In Firefox, install the Firebug extension and then enable and open the console while you're trying to upload an asset - it's the little bug icon in the bottom right of Firefox once Firebug is installed. Copy and paste the error that shows into this thread and we'll see what the problem is.

Avatar
Gina

Community Member, 11 Posts

16 March 2010 at 4:45am

Thanks so much. Installed Firebug, enabled Console, Enabled Profiler while trying to upload an asset. There are 32 calls listed here. Not sure what to paste or attach for you so please let me know if I am doing this correctly.

Also fyi - SS is displaying this error in the window:
Website Error
There has been an error
The website server has not been able to respond to your request.
Contact an administrator: noreply [at] radimage [dot] com

Thanks!

Avatar
Sean

Forum Moderator, 922 Posts

18 March 2010 at 12:18pm

Hi Gina,

Could you add this to your mysite/_config.php file, and then see if you can get the error in Firebug again?

Director::set_environment_type('dev');

Once you've got the error, you can remove the line to set the site back into "live" mode.

Cheers,
Sean