Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

can't access admin page after install - htaccess?


Reply


3 Posts   1557 Views

Avatar
hcanning

Community Member, 2 Posts

16 March 2010 at 6:47pm

Hi,
the link to the SS (latest version) admin page doesnt work. During install i get prompt saying unsure if mod rewrite is enabled. It is in htaccess?

htaccess##

### SILVERSTRIPE START ###
<Files *.ss>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Files>

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /cms-auto/silverstripe

RewriteCond %{REQUEST_URI} !(\.gif$)|(\.jpg$)|(\.png$)|(\.css$)|(\.js$)

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###

Any ideas guys? Thanks

Avatar
Sean

Forum Moderator, 922 Posts

18 March 2010 at 12:26pm

Could you check your server has mod_rewrite enabled? Also what server setup are you using, and is it a shared host?

Avatar
hcanning

Community Member, 2 Posts

18 March 2010 at 9:04pm

Hi,
I am with Godaddy and was able to install it thru the applications section in the control panel perfectly. Uploading it via ftp seemed to cause problems for me though. mod_rewrite doesnt apppear enabled in phpinfo but godaddy say it is enabled. Its a shared host.
Anyway its working now.
Thanks