Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Problems installing 2.4.0-beta2


Reply


5 Posts   997 Views

Avatar
Viv

Community Member, 30 Posts

27 March 2010 at 12:30pm

Edited: 27/03/2010 12:32pm

Trying to install a (fresh) installation of silverstripe-v2.4.0-beta2 for testing, on a server where I have had Silverstripe installations before. I am getting the following error right at the start:

Fatal error: Call to undefined function apache_get_modules() in /var/www/vhosts/(mysite)/httpdocs/install.php on line 592

This happens as soon as I enter www.(mysite).co.nz/ or www.(mysite).co.nz/install.php.

I notice looking back in the older 2.3.x versions of Silverstripe (that I have installed on this server before), this same apache function is called, so it looks like nothing new. Does someone have help with this or is it something at my web-host end that is configured incorrectly now?

Thanks for any help.

Avatar
Sean

Forum Moderator, 922 Posts

28 March 2010 at 6:39pm

This has been fixed here: [url]http://open.silverstripe.org/changeset/101357/phpinstaller/branches/2.4/install.php[/url]

It will appear in the RC1 release which should be fairly soon.

Cheers,
Sean

Avatar
Viv

Community Member, 30 Posts

28 March 2010 at 8:39pm

Thanks very much. Looking forward to trying out the changes in the 2.4 version.

Avatar
patjnr

Community Member, 101 Posts

30 March 2010 at 8:19pm

hi

me im not getting any error messages but just a blank c=screen after it has redirected to install.php.
beta 1 is working fine on the same server.

ta

PAt

Avatar
Willr

Forum Moderator, 5513 Posts

30 March 2010 at 9:51pm

PatJnr - getting anything in your php error logs?