Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[Solved] IIS 7.5: Url Rewrite...


Reply

3 Posts   5111 Views

Avatar
biapar

7 April 2010 at 12:16am (Last edited: 7 April 2010 2:06am), Forum Moderator, 435 Posts

Hi,

I've installed SS into IIS 7.5 with FastCGI and PHP addons...but there are some problems with url rewrite.
Url rewrite is ON. I've imported Apache mod_rewrite Rules from .htaccess to IIS7, but install wrote:

Friendly URLs are not working. This is most likely because a rewrite module isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:

* mod_rewrite is enabled
* AllowOverride All is set for your directory

So, if i go to /admin , I've Security/login?BackURL=%2Fss%2Fadmin

Have you had this problem?

+++++++

1) Reimporting mod_rewrites rules
2) Reinstall SS
3) It goes....

An now ... I made some tests for benchmarking on IIS...

Avatar
Sean

7 April 2010 at 10:26pm (Last edited: 7 April 2010 10:33pm), Forum Moderator, 921 Posts

Hi there,

You don't need to import any rules, just have a web.config file sitting in your SilverStripe website folder. See [url=http://doc.silverstripe.org/doku.php?id=installation-on-windows-manual-iis]here[/url] for more information.

Note that the 2.4 installer will support installing directly from IIS, as it will write the friendly URL rules into web.config for you if [url=http://www.iis.net/expand/URLRewrite]IIS URL Rewrite[/url] is installed.

Thanks,
Sean

Avatar
biapar

8 April 2010 at 8:55pm Forum Moderator, 435 Posts

Uhm..but I see that my web.config was empty...