Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Possible problem with webserver set up


Reply


2 Posts   2090 Views

Avatar
pollythena

Community Member, 2 Posts

17 April 2010 at 7:26am

As you've probably guessed by me posting in this part of the forum, I'm having a problem installing Silverstripe. I'm installing to a local server, where I've installed Apache, PHP5 and MySQL seperately (rather than through WAMP). I've used these for other things and they've worked fine, but I'm far from an expert.

On the first installation page, everything is fine, but when I click to install I see the following details:

[Warning] strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/London' for '1.0/DST' instead
POST /silverstripe/install.php

Line 298 in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\silverstripe\sapphire\core\HTTP.php

Source

289
290    /**
291     * Set the maximum age of this page in web caches, in seconds
292     */
293    static function set_cache_age($age) {
294       self::$cache_age = $age;
295    }
296
297    static function register_modification_date($dateString) {
298       $timestamp = strtotime($dateString);
299       if($timestamp > self::$modification_date)
300          self::$modification_date = $timestamp;
301    }
302
303    static function register_modification_timestamp($timestamp) {
304       if($timestamp > self::$modification_date)
Trace

strtotime(2010-04-16 19:45:43)
Line 298 of HTTP.php
HTTP::register_modification_date(2010-04-16 19:45:43)
Line 206 of DataObject.php
DataObject->__construct(Array)
Line 2538 of DataObject.php
DataObject->instance_get_one(URLSegment = 'home',)
Line 2468 of DataObject.php
DataObject::get_one(SiteTree,URLSegment = 'home')
Line 927 of SiteTree.php
SiteTree->requireDefaultRecords()
Line 212 of DatabaseAdmin.php
DatabaseAdmin->doBuild(1)
Line 793 of install.php
Installer->install(Array)
Line 123 of install.php

I suspect this is something to do with the Apache server settings but don't know what or how to fix it. Anybody able to offer any pointers?

Thanks

Avatar
Willr

Forum Moderator, 5513 Posts

17 April 2010 at 10:57pm

You need to set the date.timezone value in your php.ini file.

http://kb.siteground.com/article/How_to_change_the_datetimezone_value_in_PHP.html

Or if you can't edit your ini file then try define date_default_timezone_set('Your timezone'); at the top of your mysite/_config.php file.

http://php.net/manual/en/function.date-default-timezone-set.php