Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installing Silverstripe on 1 and 1 server


Reply


3 Posts   1341 Views

Avatar
fleisch

Community Member, 2 Posts

26 April 2010 at 3:07pm

I am trying to install Silverstripe on a 1 and 1 server. I have set up a MSql database with php 5.0 for this particular site. When I run the install.php I get:

To run SilverStripe, please install PHP 5.0 or greater.

We have detected that you are running PHP version 4.4.9. In order to run SilverStripe, you must have PHP version 5.0 or greater, and for best results we recommend PHP 5.2 or greater.

If you are running on a shared host, you may need to ask your hosting provider how to do this.

I haven't even been able to setup which database it goes to with username and password which would direct it to the MySql that is php version 5.0.

Any suggestions.

Thanks.

Avatar
Devlin

Community Member, 217 Posts

27 April 2010 at 3:01am

Edited: 27/04/2010 3:05am

Hi Fleisch,

Open the .htaccess file and add:

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Once the installation is complete you have to add both lines to the .htaccess file once again because SilverStripe has the habit to edit this file during the setup.

Edit: [url]http://hilfe-center.1und1.de/hosting/scripte_datenbanken/php/17.html?article_searchpos=1[/url]

Avatar
fleisch

Community Member, 2 Posts

28 April 2010 at 10:48am

I have changed my .htaccess file to:

### SILVERSTRIPE START ###
<Files *.ss>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Files>
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

<IfModule mod_rewrite.c>
RewriteEngine On

RewriteCond %{REQUEST_URI} !(\.gif$)|(\.jpg$)|(\.png$)|(\.css$)|(\.js$)

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>

php_value memory_limit 64M
### SILVERSTRIPE END ###

When it starts the install i get the following:

If you receive a fatal error, refresh this page to continue the installation

* Creating 'mysite/_config.php'...
* Creating /homepages/11/d248881978/htdocs/komoninn/mysite/_config.php
* Creating '.htaccess' file...
* Creating /homepages/11/d248881978/htdocs/komoninn/.htaccess
* Building database schema...
* Checking that friendly URLs work...
* Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
o mod_rewrite is enabled
o AllowOverride All is set for your directory

Any ideas where or what I should try from here. Thanks for the help!