Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Totaly green in silverstripe, can't access my homepage to install


Reply


2 Posts   1518 Views

Avatar
fjennehav

Community Member, 1 Post

4 May 2010 at 11:15pm

Hello every one.

I have uploaded all the files i my root on my linux server, when i go to my page www.fjord-hansen.dk it's says : Forbidden
You don't have permission to access / on this server.

How can i getting to install silverstripe?

Avatar
nicktacular

Community Member, 8 Posts

6 May 2010 at 3:09am

I am going to assume that you are using Apache for your web server.

By default, .htaccess files are not enabled in your web server root directory. What you need to do is change the AllowOverride directive to All in your apache httpd.conf file.

So what you do is you open up the httpd.conf file and find the section that looks like this:

<Directory "/var/www/html">
#
# Possible values for the Options directive are "None", "All",
# or any combination of:
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important. Please see
# http://httpd.apache.org/docs/2.2/mod/core.html#options
# for more information.
#
Options Indexes FollowSymLinks

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
#
AllowOverride None

#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all

</Directory>

(The /var/www/html depends on your system, so that line might reflect a different path.)

Change the AllowOverride None to AllowOverride All, restart your apache server, and reload the home page and you should see your installation.