Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

.htaccess denied


Reply

5 Posts   1329 Views

Avatar
wilsonStaff

10 May 2010 at 12:17pm (Last edited: 10 May 2010 12:18pm), Community Member, 142 Posts

Goosh, am i stupped with this thing.... Ive been "gossing" all weekend with SS and then it suddenly stopped working. So i completely reinstalled MAMP and SS and tried to reinstall SS. Now it gives me this:

/////////

User 'sabinfarley' needs to be able to write to this file:
/Applications/MAMP/htdocs/.htaccess

The file is currently owned by 'root'. We recommend that you make the file group-writeable and change the group to one of these groups:
- admin

For example:
chmod g+w /Applications/MAMP/htdocs/.htaccess
chgrp admin /Applications/MAMP/htdocs/.htaccess

////////

How in the world do i do that?

Hres a recap. I HAVE to learn SS (client requierement) but this is really not easy. Those server pitfalls are really slowing the learning curve.

Anyhow, any help appreciated.

Thanks!

Avatar
wilsonStaff

10 May 2010 at 12:41pm Community Member, 142 Posts

Still s(t)uck with that .htaccess write permission..... Really, this is not and EASY thing. I have turned in circles for HOURS before event being able to open SS..... (which i havent been able since it jammed!).

Pleeeeeeeaaaase someone......

Avatar
Hamish

10 May 2010 at 3:29pm Community Member, 712 Posts

Did you follow the instructions?

We recommend that you make the file group-writeable and change the group to one of these groups...

Avatar
Willr

10 May 2010 at 10:30pm Forum Moderator, 5511 Posts

On a Mac you can run those instructions in the terminal. Open the terminal application (in Applications/Utilities) and type the 2 lines that it reports...

chmod g+w /Applications/MAMP/htdocs/.htaccess
chgrp admin /Applications/MAMP/htdocs/.htaccess

Avatar
wilsonStaff

11 May 2010 at 1:39am Community Member, 142 Posts

I am the author of the post. I solved the problem by going backward. I mean, what did i do before the problem happened? Thing is that when i first extracted SS into the htdocs, i left the Silverstripe folder into htdocs and accessed the CMS via localhost/silverstripe/install.php

Second time, after SS (or MAMP) crashed and stalled, i extracted SS but placed the CONTENT of silverstripe/ folder directtly into htdocs/ and tried to access the CMS via localhost/install.php

Thats when .htacess came in. Once i put silverstripe/ back into htdocs/, all worked.

Will try your solution Willr.

Thanks!