Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Enabling MOD_REWRITE & GD2


Reply


4 Posts   1738 Views

Avatar
StephenDx

Community Member, 3 Posts

21 May 2010 at 10:40pm

OS: Ubuntu 10.04
Server: Apache2.2.14

I had some difficulty determining where & how-to enable GD2 & mod_rewrite.

The short of it is that in Synaptic Package Manager search for PHP5 & mark PHP5-GD for install; & mod_rewrite is a module that needs to be enabled using

sudo a2enmod

followed by

rewrite

.

More info on mod_rewrite at [url]http://ubuntuforums.org/showthread.php?t=903386[/url] (the reason

httpd.conf

is empty given at [url]http://ubuntuforums.org/showthread.php?t=278531[/url]).

And yes, if you think this makes me sound like a newbie, I am. However, it would have helped if this had been available here rather than having to go hunt for it. Helpful tips & hints always make things go smoother. :) So why not? ... I found an answer that some may be looking for.

Unfortunately, my day job has me working with Microsoft systems (the "so called" Dark Side ;), so my Linux experience is limited at the moment.

Avatar
StephenDx

Community Member, 3 Posts

21 May 2010 at 11:21pm

Edited: 21/05/2010 11:30pm

Also had an issue with AllowOverride not allowed. Tracked this one down again to the fact that httpd.conf is no longer used. Check into a file in the folder /etc/apache2/sites-enabled (for me it was) 000-default which had the AllowOverride defined in it. Changed 'none' to 'all' & success! Finally!

I'm loving the experience although it is a bit frustrating finding some of these things out. :)

BTW: the filename 000-default is zero zero zero dash (or hyphen) default.

Avatar
Willr

Forum Moderator, 5513 Posts

22 May 2010 at 9:31pm

I think it should just be a case of running the following to get GD support.

sudo apt-get install php5-gd

Avatar
lanks

Community Member, 61 Posts

2 September 2010 at 9:42pm

Thanks for this StephenDx.

With a default install of ubuntu and apache2 installing php5-gd and enabling mod_rewrite isn't enough to get it going. Setting AllowOverride to "All" for the "/var/www/" directory is the required step to get rewriting to work.