Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installation Problem on Zend Server


Reply


5 Posts   2270 Views

Avatar
TomMiller

Community Member, 26 Posts

18 June 2010 at 12:33am

Hi community,
i'm trying to install silverstripe 2.4.0 on a Zend Server Comunity Edition 5.0.0 - PHP 5.3.1 on Windows XP.

I get 2 warnings:
Server software: Unknown web server
URL rewriting support: You need mod_rewrite to use friendly URLs with SilverStripe, but it is not enabled.

Zend is using Apache/2.2.14. Mod_rewrite is loaded an and AllowOverride All is set for the Silverstripe directory in the httpd.conf like this:
<Directory "C:\Programme\Zend\Apache2/htdocs/silverstripe-v2.4.0/">
Options FollowSymLinks SymLinksifOwnerMatch
AllowOverride All
Order allow,deny
Allow from all
</Directory>

Is there any chance to get past these warnings?

Thanks in advance,
Tom

Avatar
Sean

Forum Moderator, 922 Posts

18 June 2010 at 1:59am

Have you tried just installing anyway?

I'm not sure, but does Apache allow use of back slashes and forward slashes interchangeably the way the "Directory" directive has in your example?

Avatar
TomMiller

Community Member, 26 Posts

18 June 2010 at 11:34pm

Just tried installing anyway.
After a second i'm getting an error:
Warning: "date() [function.date]: It is not safe to rely on the system's timezone settings.
You are *required* to use the date.timezone setting or the date_default_timezone_set() function.
In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier.
We selected 'Europe/Paris' for '2.0/DST' instead" at line 79 of C:\Programme\Zend\Apache2\htdocs\silverstripe-v2.4.0\sapphire\core\model\fieldtypes\Datetime.php.

Is it a good idea to rewrite line 79: return DBField::create('SS_Datetime', date('Y-m-d H:i:s')); to fit european date-time-format?

The Zend httpd.conf uses a combination of back- and forward-slashes. I played with changing all to forward, or all to backslashes - made no difference...

Avatar
Sean

Forum Moderator, 922 Posts

19 June 2010 at 11:34pm

Edited: 19/06/2010 11:59pm

date.timezone needs to be defined in php.ini. This is a requirement from PHP themselves, not a SilverStripe specific issue.

e.g.

date.timezone = Europe/Paris

This is set to nothing by default in php.ini, so you'll have to get in there and add your timezone manually.

Hope that helps.

Cheers,
Sean

Avatar
TomMiller

Community Member, 26 Posts

21 June 2010 at 8:01pm

Installation problems solved.
Thanks a ton!
Tom