Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Zend issue when try to access Admin panel after Installation


Go to End
Reply

10 Posts   3126 Views

Avatar
BridC

28 June 2010 at 4:49pm (Last edited: 28 June 2010 5:30pm), Community Member, 6 Posts

Hi everyone,

I've just managed to install Silverstripe on with my hosting company. However when I try to access the admin panel. I get the following:

Warning: require_once(Zend/Log.php) [function.require-once]: failed to open stream: No such file or directory in /****/public_html/sapphire/dev/Log.php on line 2

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Log.php' (include_path='./***/public_html/sapphire:/***/public_html/sapphire/parsers:/***/public_html/sapphire/thirdparty:/usr/local/lib/php') in /home/massmaor/domains/***/public_html/sapphire/dev/Log.php on line 2

I've had a look through the existing posts and they say i need to add in php_admin_value. I can't figure out what file I need to change. Do I edit the _config.php file or the .htaccess file.

Any help would be appreciated just starting using Silverstripe and finding this a little confusing. Thanks in advance.

Avatar
Willr

28 June 2010 at 7:05pm Forum Moderator, 5511 Posts

Hi BridC, Welcome to the forums.

Please see these threads for answers

http://silverstripe.org/installing-silverstripe/show/284048?start=0#post284114
http://silverstripe.org/installing-silverstripe/show/282431#post282431
http://silverstripe.org/installing-silverstripe/show/284627#post284627

The solution is to add your sapphire folder to your include path. This article has more information on how to set your include_path http://support.modwest.com/content/5/98/en/how-do-i-set-php-include_path.html

Avatar
BridC

28 June 2010 at 7:39pm Community Member, 6 Posts

Hi Willr,

thanks for getting back to me, I had read through the posts you mentioned and still got confused.

Do I need to set the include_path inside the .htaccess file or inside the sapphire/_config.php.

Thanks.

Avatar
Willr

28 June 2010 at 7:46pm Forum Moderator, 5511 Posts

You can set it in either. I think .htaccess would be better than the _config file but both should work.

Avatar
BridC

28 June 2010 at 8:13pm Community Member, 6 Posts

Hi Willr,

I've put it in the sapphire/_config.php, as I couldn't get access to edit the .htaccess file on my hosting site.

I don't think I have the correct syntax though.

php_value include_path = “.:/home/massmaor/domains/mass.maori.nz/public_html/sapphire:/home/massmaor/domains/mass.maori.nz/public_html/sapphire/thirdparty:/home/massmaor/domains/mass.maori.nz/public_html/sapphire/parsers/";

This is the original error msg i was getting:

Warning: require_once(Zend/Log.php) [function.require-once]: failed to open stream: No such file or directory in /home/massmaor/domains/mass.maori.nz/public_html/sapphire/dev/Log.php on line 2

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Log.php' (include_path='.:/home/massmaor/domains/mass.maori.nz/public_html/sapphire:/home/massmaor/domains/mass.maori.nz/public_html/sapphire/parsers:/home/massmaor/domains/mass.maori.nz/public_html/sapphire/thirdparty:/usr/local/lib/php') in /home/massmaor/domains/mass.maori.nz/public_html/sapphire/dev/Log.php on line 2

Avatar
BridC

28 June 2010 at 8:24pm (Last edited: 28 June 2010 8:24pm), Community Member, 6 Posts

php_value include_path = .:/home/massmaor/domains/mass.maori.nz/public_html/sapphire:/home/massmaor/domains/mass.maori.nz/public_html/sapphire/parsers:/home/massmaor/domains/mass.maori.nz/public_html/sapphire/thirdparty/Zend/Log.php;

I just also tried the above aswell and still getting errors.

Avatar
Willr

28 June 2010 at 8:37pm Forum Moderator, 5511 Posts

Try

ini_set("include_path", ".:../:./home/massmaor/domains/mass.maori.nz/public_html/sapphire:/home/massmaor/domains/mass.maori.nz/public_html/sapphire/thirdparty:/home/massmaor/domains/mass.maori.nz/public_html/sapphire/parsers");

at the top of your _config file (after the <?php). Some hosts also disable ini_set, php_value so check with your hosting provider that AllowOverride is set to something that allows you to edit it 'Options' or 'All'.

See http://www.sitepoint.com/forums/showthread.php?t=549437 for some more info.

Avatar
BridC

28 June 2010 at 9:05pm Community Member, 6 Posts

Hi Willr,

i tried that and still getting an error. Thanks for your help I really appreciate it. I'll check with the hosting provider ion the morning about the ini_set, php_value

Go to Top