Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Issues Running SS 2.4.1


Reply


740 Views

Avatar
Jnauta

Community Member, 8 Posts

19 August 2010 at 1:01am

Edited: 19/08/2010 2:07am

Hello there, I have several silverstripe installations running, and now I am making the transition to SS for my own site. I installed 2.4.2 and i am having the constant Memory "Fatal Error" on top of that issue, my popups for ManyManyComplexTableFields are trying to OPEN the html file and not LOAD the file. Every time i attempt to add a Record to the table, the browser asks where i want to save the file. I'm really at a loss here.

the script i think that I am having an issue with is the Loader JS in "saphire/thirdparty/greybox/loader_frame.html", I'm not sure if the script is the problem or the way it is trying to load the DataObject Class that I am trying to edit.

Here is the DataObject Class :
class Visual extends DataObject {
   static $db = array(
      'VisualName' => 'Text'
   );
   
   static $has_one = array(
      'VisualImage' => 'Image'
   );

   static $belongs_many_many = array(
      'Project' => 'ProjectPage',
      'Clients' =>'Client'
   );

   // Used for TableField. These are the field names.
   // Refer to getCMSFields() on ArticleHolder for how it is used.
   static $field_names = array(
      'VisualName' => 'Visual Name',
      'VisualImage' => 'Visual Image',
   );

function getCMSFields_forPopup() {
$fields = new FieldSet();
$fields->push( new TextField( 'VisualName', 'Visual Name' ) );
$fields->push( new FileIframeField( 'VisualImage', 'Visual Image' ) );
return $fields;
}
}