Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

silverstripe MS- SQL installation problem


Reply

26 Posts   5012 Views

Avatar
dips_045

23 November 2010 at 10:45am Community Member, 20 Posts

Thanks again Sean! Everything works fine on my local machine. I am having trouble putting the website live. When I uploaded the folder onto my server I got this message:

Sorry, there was a problem with handling your request.
Visit www.silverstripe.org to download the CMS

Warning: Unknown: open(C:\inetpub\conf\temp\sess_ouf8ighfhbkk8evk278lrphjn7, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\inetpub\conf\temp) in Unknown on line 0

How can I put my website live onto my host?

Many thanks again

Avatar
Sean

23 November 2010 at 10:53am (Last edited: 23 November 2010 10:55am), Forum Moderator, 921 Posts

C:\inetpub\conf\temp does not seem writable by PHP. You have two choices

1. Ask your host to make this writable for you... or:
2. Create a silverstripe-cache folder in the directory where SilverStripe is installed, and make it writable to PHP/IIS by assigning the user IUSR writable permissions (see my previous post in this thread on setting permissions on Windows).

Then, add the following code at the start of mysite/_config.php like this:

<?php

session_save_path(getTempFolder());
ini_set('upload_tmp_dir', getTempFolder());

...

This will then store any session files in the silverstripe-cache folder, instead of the system temp path which doesn't appear to be writable in your case.

Sean

Avatar
dips_045

23 November 2010 at 10:58am (Last edited: 23 November 2010 11:02am), Community Member, 20 Posts

Thanks! I have emailed my host! hopefully it'll work. Will post how I get on tomorrow!
Many thanks :)

Avatar
dips_045

23 November 2010 at 11:17am Community Member, 20 Posts

Hi again,

There is a conf folder in the sapphire folder but no temp?

What am I asking to be made writable?

Thanks

Avatar
Sean

23 November 2010 at 11:20am (Last edited: 23 November 2010 11:21am), Forum Moderator, 921 Posts

From the looks of it, C:\inetpub\conf\temp is a system temp folder, not a folder contained within the website code.

Ask your host for PHP write permission to C:\inetpub\conf\temp

Avatar
dips_045

23 November 2010 at 11:26am Community Member, 20 Posts

Thanks, I have emailed my host. Many thanks for your quick repsonses much appreciated :)

Avatar
dips_045

25 November 2010 at 11:45am (Last edited: 25 November 2010 11:52am), Community Member, 20 Posts

Hi again,

My host got back to me today:
Unfortunately, as you are on a shared server we would not be able to permit this.

Parent paths are disabled by default on Easily Windows servers.
This means that if you attempt to use code such as
MyPath = Server.MapPath("../includes/myfile.inc")
or

...you will get an error:
Active Server Pages error 'ASP 0131'

Disallowed Parent Path
The Include file 'filename' cannot contain '..' to indicate the parent directory.
You need to either specify the full path to the file (E:\Inetpub\ntXXXX\website\\), or specify the virtual path relative to the root 'website' folder (//), e.g.
MyPath = Server.MapPath("/includes/myfile.inc")

I'm not sure what that means?

I also tried the second choice in your previous post. I created a folder called 'silverstripe-cache' (with user group write permissions) and pasted the following code in mysite/_config.php:
session_save_path(getTempFolder());
ini_set('upload_tmp_dir', getTempFolder());

I get loads of new errors like this:
Warning: fopen(E:\Inetpub\win8228\website\ss24test/silverstripe-cache/manifestClassParse-AssetAdmin_php-e3d4c6e28b45b73d7132a471886faba3) [function.fopen]: failed to open stream: Permission denied in E:\Inetpub\win8228\website\ss24test\sapphire\core\ManifestBuilder.php on line 466

Warning: fopen(E:\Inetpub\win8228\website\ss24test/silverstripe-cache/manifestClassParse-AssetTableField_php-58c8b36fbef52cb4fd34d1043b82964a) [function.fopen]: failed to open stream: Permission denied in E:\Inetpub\win8228\website\ss24test\sapphire\core\ManifestBuilder.php on line 466

What should I do?

Avatar
Sean

28 November 2010 at 2:43am Forum Moderator, 921 Posts

Instead of giving the Users group write permissions to silverstripe-cache, have you tried just giving the IUSR user write permissions?