Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SS 2.4.1 installation issues


Reply


8 Posts   1967 Views

Avatar
Christy

Community Member, 57 Posts

30 July 2010 at 10:50pm

Edited: 30/07/2010 11:01pm

I have installed 2.4.1 on the web server with the black candy theme before adding custom theme etc. After much trial and error and reloading I am down to three problems (I think!). In no particular order:

1- to access the cms/flush I have to include index.php in the address- for example, ip address/~domain/index.php/admin (test site on Nucleus isp)
2- seem to be in an infinite loop continually being asked to login, or rather, login as someone else.
3- page type says "change to error page" on most pages - (PHP for custom pages has been uploaded)

Rebuilding the database includes the below each time

# Page
# Index Page_versions.RecordID_Version: changed to unique (RecordID, Version) (from unique (RecordID,Version))
# Homepage
# Index Homepage_versions.RecordID_Version: changed to unique (RecordID, Version) (from unique (RecordID,Version))
# Quadpage
# Sidebarpage
# Index Sidebarpage_versions.RecordID_Version: changed to unique (RecordID, Version) (from unique (RecordID,Version))
# SiteMap
# Wines
# Index Wines_versions.RecordID_Version: changed to unique (RecordID, Version) (from unique (RecordID,Version))
# ErrorPage
# Index ErrorPage_versions.RecordID_Version: changed to unique (RecordID, Version) (from unique (RecordID,Version))
# RedirectorPage
# Index RedirectorPage_versions.RecordID_Version: changed to unique (RecordID, Version) (from unique (RecordID,Version))
# VirtualPage
# Index VirtualPage_versions.RecordID_Version: changed to unique (RecordID, Version) (from unique (RecordID,Version))

Any help would be very much appreciated.

=====Note - have just read in a post that duplicating the page and renaming solves the page type problem.=============

Avatar
Christy

Community Member, 57 Posts

31 July 2010 at 12:52pm

Now I have zipped my development site and uploaded that and a new copy of the database. Then changed database details in the config file.

=index.php still needs to be included in the address
=page types are now OK although the messages have returned to the database rebuild
=still being asked to log in when accessing a draft page. (all pages have been published automatically)

The log in issue is the worst. Any thoughts please?

Avatar
Willr

Forum Moderator, 5513 Posts

31 July 2010 at 6:25pm

Edited: 04/08/2010 4:20pm

index.php still needs to be included in the address

mod_rewrite doesn't sound like it has been correctly setup on your server. You will need mod_rewrite to use 'nice' urls like /page/. Check with your host whether you have access to mod_rewrite and ensure there is a '.htaccess' file in your websites root folder (windows may hide this file from you but it needs to be there)

=still being asked to log in when accessing a draft page. (all pages have been published automatically)

This is standard. You have to login to see draft content.

Avatar
Christy

Community Member, 57 Posts

4 August 2010 at 2:47pm

Thank you for your help, Willr.

Nucleus (Digital Network) assured me that mod_rewrite is turned on and the .htaccess is present.

Its contents are:
### SILVERSTRIPE START ###
<Files *.ss>
   Order deny,allow
   Deny from all
   Allow from 127.0.0.1
</Files>

<Files web.config>
   Order deny,allow
   Deny from all
</Files>

<IfModule mod_rewrite.c>
   RewriteEngine On
   RewriteCond %{REQUEST_URI} ^(.*)$
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###

Thanks. - Otherwise - looking good!

Avatar
DsX

Community Member, 178 Posts

3 October 2010 at 7:09am

I have what I believe is a related problem.
I have a site I am developing, and things are going great.
If I load http://testsite.local the site loads perfectly to the home page as I would expect.
If I load http://testsite.local/index.php the html for the page loads but every element linked to the page is looking for something like: http://testsite.local/index.php/index.php/sapphire/thirdparty/behaviour/behaviour.js?m=1267739533 (this is one of the JS includes toward the bottom of the page), and any locally referenced items from my themes directory are failing to link, so I can only guess they are being routed as: http://testsite.local/index.php/index.php/themes/...etc...

now this is all running on my local xampp install and I have other sites I have developed on this install as well, and it seems fine.
Does the .htaccess included with silverstripe know how to reroute the request to index.php? or..

Christy did you have any luck getting past this?

Avatar
Willr

Forum Moderator, 5513 Posts

8 October 2010 at 9:26am

Christy - also check that AllowOverride is set to all or to the path of your .htaccess. If you cannot override it then you're outta luck.

DsX - if mod_rewrite is working fine then delete the index.php as you don't need it.

Avatar
Christy

Community Member, 57 Posts

8 October 2010 at 2:40pm

Ahhhhhh don't know!

Allowoverride was set to all and mod_rewrite enabled. (Thanks, Willr)

On the test site - before the A record was pointed to it - I solved the index.php problem by following this post:
http://www.silverstripe.org/general-questions/show/292147#post292147

and adding below to the .htaccess file.
RewriteBase /sssite
RewriteCond %{REQUEST_URI} sssite$
RewriteRule (.*) $1/ [L]

When the site went live, it was including an extra /sssite/ in the address but working OK - if that makes sense.

The lines added to the .htaccess file have been removed and address is as it should be.

But why?? That is the question?

Avatar
DsX

Community Member, 178 Posts

14 October 2010 at 6:24am

Willr

I will test that, thanks.
One concern I have is that for debugging I need to set a default file in my IDE, any idea how to work around this?