Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

username/password eror during installation


Reply

3 Posts   1058 Views

Avatar
Harrycus Prime

22 July 2010 at 1:22am Community Member, 2 Posts

Hello all,

My first time using SilverStripe and I have hit a stumbling block on the installation. I have spent several hours trying to sort the problem but just cannot seem to.

I have installed plenty of Wordpress/Zen Cart/etc sites and the setup procedure is very similar.

Every time I try and enter the database details on the install.php page I get the following;

"Database access credentials correct"
"That username/password doesn't work:"

This may sound silly but do I need to enter the details below to the _config file manually prior to installation or should the install do it manually.

"type" => "MySQLDatabase",
   "server" => "localhost",
   "username" => "",
   "password" => "",
   "database" => "",

Any help would be greatly appreciated.

Avatar
Harrycus Prime

22 July 2010 at 3:00am Community Member, 2 Posts

Just an update.

I managed to get it working by doing the following;

Server: 127.0.0.1
Username: root
Password: left it blank
Database Name: "mydatabase"

Not sure if this is safe or not but Silverstripe installed.

Avatar
Sean

22 July 2010 at 2:32pm Forum Moderator, 921 Posts

No database password is generally fine in a development environment, but not in production.

127.0.0.1 and localhost are the same, so no problem there.

Cheers,
Sean