Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Windows Install Error


Go to End
Reply

9 Posts   1874 Views

Avatar
rcricken

7 October 2010 at 9:52am Community Member, 3 Posts

Hi, I am having some issues getting SS functioning correctly. I followed directions from http://doc.silverstripe.org/installation-on-windows-server-manual-iis to manually install to an IIS server on Windows 7. When I attempt to run the site http://localhost/ss24 I receive the error [Warning] mysql_connect(): [2002] A connection attempt failed because the connected party did not (trying to connect via tcp://localhost:3306). I am not sure what would be causing this issue and any help is greatly apprecaited.

Avatar
Sean

7 October 2010 at 9:56am (Last edited: 7 October 2010 9:57am), Forum Moderator, 921 Posts

And you get this error when going to install.php?

It looks like you haven't set the database details correctly...

Please make sure your working copy is clean, and you're using the original mysite/_config.php from the downloaded SilverStripe package.

Sean

Avatar
rcricken

7 October 2010 at 10:06am Community Member, 3 Posts

No, the error is when I attempt to go to index.php. The copy of _config.php under mysite directory is the original downloaded file. I believe in the instructions it asks for you to input a database name into the file but other than that no changes where made. If I browse to install.php I get several errors regarding permissions...

Is the web.config file writeable? The webserver user needs to be able to write to this file:
C:\inetpub\wwwroot\ss24\web.config
Is the mysite/_config.php file writeable? The webserver user needs to be able to write to this file:
C:\inetpub\wwwroot\ss24\mysite\_config.php
Is the assets/ folder writeable? The webserver user needs to be able to write to this file:
C:\inetpub\wwwroot\ss24\assets

And a database error:

Database server I couldn't find a database server on 'localhost': A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

If I add "Everyone" to allow full control at inetpub folder the access errors go away but still doesnt resolve initial problem browsing to index.php.

Avatar
Sean

7 October 2010 at 10:37am Forum Moderator, 921 Posts

I think that's where the instructions are wrong. I've removed the section that indicated changing the database name from "" to "ss24".

The installer should take care of this for you.

Could you try setting it back to "" then going to http://localhost/ss24?

Cheers,
Sean

Avatar
rcricken

7 October 2010 at 12:34pm Community Member, 3 Posts

Hi Sean: After removing the database name from that file it worked perfectly. Thanks so much for your help and quick response.

Avatar
Sean

7 October 2010 at 1:42pm Forum Moderator, 921 Posts

Great to hear!

I need to add a section to that documentation which shows you how to add a default document of index.php. IIS doesn't do this by default when you're adding a new "Handler Mapping" entry for PHP.

Cheers,
Sean

Avatar
biapar

8 October 2010 at 9:31am Forum Moderator, 435 Posts

You can use IIS Web Gallery to install PHP.
So, Web Gallery config IIS to run PHP.
I suggest to install WinCache, too.

Avatar
Sean

8 October 2010 at 9:37am Forum Moderator, 921 Posts

biapar: Yes, but this is a manual install, and the advantage is you install a VC9 version of PHP 5.3 instead of VC6 of PHP 5.2 which WebPI installs. VC9 compiles are faster than VC6 and 5.3 is also faster than 5.2. There's also full control over the process, so you learn how to setup PHP via FastCGI with IIS.

Wincache is also covered by the guide, and yes it's a recommended installation.

Go to Top