Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

/admin?isDev=1 on SS2.4.2


Go to End
Reply


19 Posts   3513 Views

Avatar
zenmonkey

Community Member, 532 Posts

9 October 2010 at 2:46am

I'm still having the issue where I need to append ?isDev=1 to get into the admin. Thought it was sorted out in 2.4.2

Anyone else still having this issue?

Cheers,

Avatar
dalesaurus

Community Member, 283 Posts

9 October 2010 at 6:18am

No problem here both on 2.4.2 stable and dev branch

Avatar
Sean

Forum Moderator, 922 Posts

9 October 2010 at 8:30pm

I haven't seen anything like this during our testing. When you say you can't get in to admin, what does that mean specifically? 500 server error, 404?

Avatar
zenmonkey

Community Member, 532 Posts

13 October 2010 at 2:11am

According to firebug, it seems to generate a bunch of JavaScript Errors:

Class ss.i18n not defined
http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js
Line 30

Class ss.i18n not defined
http://domain.com/cms/javascript/lang/en_US.js?m=1260757610
Line 2

jQuery is not defined
http://domain.com/sapphire/javascript/SilverStripeNavigator.js?m=1268282238
Line 35

Behaviour is not defined
http://domain.com/cms/javascript/SitetreeAccess.js?m=1266820038
Line 18

Class is not defined
http://domain.com/sapphire/javascript/tiny_mce_improvements.js?m=1270017450
Line 1

jQuery is not defined
http://domain.com/sapphire/thirdparty/jquery-form/jquery.form.js?m=1268274558
Line 665

jQuery is not defined
http://domain.com/sapphire/javascript/HtmlEditorField.js?m=1264719398
Line 81

Behaviour is not defined
http://domain.com/admin
Line 614

Behaviour is not defined
http://domain.com/admin
Line 863

Behaviour is not defined
http://domain.com/admin
Line 919

Behaviour is not defined
http://domain.com/admin
Line 975

Behaviour is not defined
http://domain.com/admin
Line 992

Behaviour is not defined
http://domain.com/admin
Line 1054

Any help would be appreciated, I don't want to keep running my site in Dev mode :)

Avatar
dalesaurus

Community Member, 283 Posts

13 October 2010 at 3:16am

You aren't using the ss_environment switcher method by any chance? It looks like you paths in dev mode are correct, but prod are not. Looks to be a matter of adjusting permissions/includes.

Avatar
zenmonkey

Community Member, 532 Posts

13 October 2010 at 4:28am

I'm not using the ss_enviroment switcher anywhere. I tried setting the following dirs and contents to 755

cms/javascript
saphire/behavior
saphire/javascript
saphire/jquery-???
saphire/tinymce
saphire/tinymne-advcode

Still getting errors, just in different places

Avatar
dalesaurus

Community Member, 283 Posts

13 October 2010 at 6:14am

Well it looks like this is back to server troubleshooting 101.

  • Trace down the path of the files that are throwing 404 in firebug, be sure they actually exist where the server config thinks they should be.
  • Check your webserver's logs to see if it is throwing out any errors or clues.
  • Try doing a fresh install to another directory to ensure it isn't your code or corrupted code.

Drop this in somewhere in a _config.php and see if you get any other errors

ini_set("display_errors", 1);
error_reporting(E_ALL);

Avatar
zenmonkey

Community Member, 532 Posts

13 October 2010 at 9:08am

Only error I'm seeing that remotely coincides with Admin logins is:

[Tue Oct 12 14:50:35 2010] [error] [client 69.165.220.52] PHP Warning: No current controller available in /var/www/vhosts/domain.com/httpdocs/sapphire/core/control/Controller.php on line 365
[Tue Oct 12 14:50:35 2010] [error] [client 69.165.220.52] PHP Fatal error: Call to a member function getSession() on a non-object in /var/www/vhosts/domain.com/httpdocs/sapphire/core/Session.php on line 210

The JS files aren't generating any 404s. And I'm using the same code on other machine. But I'll have my IT guys set me up another install on the same machine.

Go to Top