Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Fatal Error


Go to End
Reply

16 Posts   2701 Views

Avatar
Adizo

17 October 2010 at 2:26am Community Member, 12 Posts

i get this error after installation
Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\silverstripe\sapphire\core\ManifestBuilder.php on line 458
Does anyone know how i can fix this?

Avatar
Sean

18 October 2010 at 11:33am (Last edited: 18 October 2010 11:36am), Forum Moderator, 921 Posts

Where does this occur? Any screenshots you could provide to give some context?

You can also force the execution time up by setting a few things at the top of mysite/_config.php _before_ starting the installation:

ini_set('max_execution_time', 300);
set_time_limit(300);

Avatar
Adizo

22 October 2010 at 1:18pm Community Member, 12 Posts

After trying to reinstall the is the error message i get:
Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Setting up 'mysite/_config.php'...
Setting up C:\xampp\htdocs\silverstripe\mysite/_config.php
Setting up '.htaccess' file...
Setting up C:\xampp\htdocs\silverstripe\.htaccess
Building database schema...

[Warning] date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Paris' for '1.0/no DST' instead
POST /silverstripe/install.php

Line 89 in C:\xampp\htdocs\silverstripe\sapphire\core\model\fieldtypes\Datetime.php
Source

80     * Returns either the current system date as determined
81     * by date(), or a mocked date through {@link set_mock_now()}.
82     *
83     * @return SS_Datetime
84     */
85    static function now() {
86       if(self::$mock_now) {
87          return self::$mock_now;
88       } else {
89          return DBField::create('SS_Datetime', date('Y-m-d H:i:s'));
90       }
91    }
92    
93    /**
94     * Mock the system date temporarily, which is useful for time-based unit testing.
95     * Use {@link clear_mock_now()} to revert to the current system date.
Trace

date(Y-m-d H:i:s)
Line 89 of Datetime.php
SS_Datetime::now()
Line 1023 of DataObject.php
DataObject->write()
Line 1297 of SiteTree.php
SiteTree->requireDefaultRecords()
Line 231 of DatabaseAdmin.php
DatabaseAdmin->doBuild(1)
Line 1026 of install.php
Installer->install(Array)
Line 190 of install.php

Avatar
Sean

22 October 2010 at 1:20pm (Last edited: 22 October 2010 1:21pm), Forum Moderator, 921 Posts

Open up your php.ini file (in C:\xampp somewhere) and look for date.timezone and make it look like this:

date.timezone = Europe/Paris

This is a setting which should always be set in PHP and is therefore not a SilverStripe issue.

Sean

Avatar
Adizo

22 October 2010 at 1:22pm Community Member, 12 Posts

ok. will do that now and get back to you.

Avatar
Sean

22 October 2010 at 1:24pm Forum Moderator, 921 Posts

You can refer to http://php.net/manual/en/timezones.php if you're not sure which timezone should be set.

Avatar
Adizo

22 October 2010 at 1:26pm Community Member, 12 Posts

same error message. i restarted server... did everything. but same problem

Avatar
Sean

22 October 2010 at 1:28pm Forum Moderator, 921 Posts

What did you set the date.timezone setting as?

Go to Top