Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

do i get the right installation file?


Reply


2 Posts   726 Views

Avatar
imin

Community Member, 1 Post

11 November 2010 at 2:41pm

hi

i've tried downloading the latest silverstripe numerous times from the official download link http://silverstripe.org/assets/downloads/SilverStripe-v2.4.2.tar.gz .In the tar.gz file, there's a .tar file, named silverstripe-v2.4.2.tar. and when I extract the silverstripe-v2.4.2.tar file, I only get these files and folders:

[folder]sapphire
[files] Makefile
[files] favicon.ico

and in the [folder] sapphire, there's these files and folders:
[folder]widgets
[folder]tests
[folder]templates
[folder]search
[folder]lang
[folder]cli
[folder]api
[files]static-main.php
[files]sake
[files]Makefile

and obviously, when I put the folder sapphire into my localhost folder, and tried accessing http://localhost/sapphire/ there's nothing to be seen there. I expect there should be some index.php file or something, right? I've tried downloading from the link above a few times, and the files are the same.....

Avatar
Willr

Forum Moderator, 5513 Posts

11 November 2010 at 5:39pm

You do not need an index.php as SS will attempt to use mod_rewrite for the URLs. It does appear how ever that you are missing an install.php. See the default files which you should have (as well as sapphire/ cms/) in the installer - http://open.silverstripe.org/browser/phpinstaller/tags/2.4.2