Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

session.use_cookies=Off


Reply


4 Posts   1759 Views

Avatar
logiciel

Community Member, 2 Posts

18 December 2010 at 1:44am

We have developed a Silverstripe site on a local server, this works fine.
But on the live server we get problems with login, with creating of Redirector page, with staying logged in, with uploading of images in ImageGallery etc.
Some live server settings are not standard, for example

session.use_cookies=Off ;
session.use_trans_sid=1;
session.name is not PHPSESSID

I think the session.use_cookies makes the troubles and must be set to On.
Do I have right?
Can Silverstripe properly work with session.use_cookies=off?

Avatar
Sean

Forum Moderator, 922 Posts

18 December 2010 at 7:39pm

Edited: 18/12/2010 7:48pm

I'm not sure this will work, but you could try adding this to the top of sapphire/core/Core.php just underneath the <?php tag:

ini_set('session.use_cookies', '1');
ini_set('session.use_trans_sid', '0');
ini_set('session.name', 'PHPSESSID');

If that doesn't work, add this to the .htaccess file instead:

php_value session.use_cookies 1
php_value session.use_trans_sid 0
php_value session.name PHPSESSID

Sean

Avatar
logiciel

Community Member, 2 Posts

19 December 2010 at 5:26am

Thank you, I have already tested with ini_set('session.use_cookies', '1') in mysite/_config.php, it seems to work.
The setting session.use_cookies=1 is not mentioned in silverstripe documentation as required, therefore I have asked.

Avatar
Sean

Forum Moderator, 922 Posts

19 December 2010 at 12:35pm

Edited: 19/12/2010 12:36pm

It's not mentioned, but there are certain PHP configuration options we miss out. I don't believe it's common to disable cookies for sessions, hence why we haven't discovered this until you raised the issue. Paranoid web host?