Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

date.timezone option in php.ini must be set in PHP 5.3.0+


Go to End
Reply


17 Posts   68663 Views

Avatar
jamiecam43

Community Member, 1 Post

10 January 2011 at 6:02am

I am beyond frustrated. I have confirmed with PHPinfo which php.ini file is being loaded, and double checked that it has the date.timezone set to "Canada/Eastern". other posts online seem to indicate that the quotations shouldn't be there so i delete them, save the file, restart the server and try to install again but it continues to fail. on further investigation the quotations have returned every time i restart the server.

i am using a Mac so i tried running a command in terminal to see what value date.timezone contained and it says no value. i am new to this sort of thing and very confused. can anybody help?

Avatar
Sean

Forum Moderator, 922 Posts

10 January 2011 at 12:02pm

Are you using the default PHP that comes with Mac OS X? I haven't seen this when using PHP provided by MacPorts.

Avatar
seidlitz

Community Member, 1 Post

11 January 2011 at 10:35pm

Hi Jamie,

I ran into the same issue. Tried using "Canada/Pacific" and got the same error message as you. Looks like PHP is not aware of Canada ;-) Changed my timezone to "America/Vancouver", restarted Apache and it cleared the error.

Check [url=http://nz.php.net/manual/en/timezones.america.php]this[/url] page for the list of North American timezones recognized by PHP and pick something close to you e.g. "America/Toronto"

Cheers,

Alex

Avatar
rjmau

Community Member, 2 Posts

12 March 2011 at 8:44pm

i have the same problem. Timezone for PHP is not set. Please set "date.timezone" option in php.ini.
*
date.timezone = Asia/Manila
*
this is my code. i search it through the web. and still the same error occurs please help me with this problem
i've been finding a way for quite some time now. any idea how to fix this?

i've tried adding double quotes, single quote and even no quote. so im really confused. please help me.
thanks in advance guys =)

Avatar
rjmau

Community Member, 2 Posts

12 March 2011 at 9:50pm

here is a snap shot of my problem. i attached the file

Attached Files
Avatar
prawnstar

Community Member, 127 Posts

2 April 2011 at 3:32pm

I have the same issue and I'm on an Ubuntu machine.

php.ini

; http://php.net/date.timezone
date.timezone = America/Los_Angeles

Chris.b

Avatar
MrMuddy

Community Member, 13 Posts

21 April 2011 at 9:43am

Weirdly, I've just run into the same problem. On a PHP 5.2 server, I have many SS installations with no issues.. On a different machine (PHP 5.3.2-1ubuntu4.7) I get the same error as others on the installation screen.

My timezone is set as Europe/London in php.ini and this is confirmed by phpinfo()

Any ideas appreciated !

Avatar
Bruce B

Community Member, 147 Posts

7 May 2011 at 7:04pm

I just hit this error on a new install of 2.4.5. I'm running a Mac using the native Apache/PHP. My timezone was set to Australia/ACT. This is a valid entry and confirmed in phpinfo(). I changed it to Australia/Melbourne and SS is now happy to proceed.

It may be worth changing the timezone and changing back to see if that fixes the problem.

Go to Top