Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

/dev/build not running


Reply


5 Posts   3018 Views

Avatar
skwok

Community Member, 2 Posts

11 February 2011 at 5:25am

Edited: 12/02/2011 4:22am

Hi! I have been asked to setup Silverstripe on our Windows 2003 Server to host a website that a developer created under the Linux version of Silverstripe and apparently a slightly older one. They did a tar backup of the file and basically dumped it in my lap. Naturally, because of the OS and version differences, I"m having some trouble integrating the two.

The Windows Silverstripe installer installed Silverstripe 2.4.5 successfully. I did an import of the existing MySQL database, did some php.ini and _config.php tweaking, found a missing priority field in sitetree and sitetree live which lead me to the point where it is asking me to do a /dev/build, but no matter what I try I just cant seem to get this command to run. (http://test.mackieconsult.com/dev/build")

Any help would be appreciated, I've exhausted any ideas I've had to get this to work properly.

Test website is at: http://test.mackieconsult.com
IIS 6.0 Web Server Homedirectory is set to c:/inetpub/wwwroot/mackieconsult.com/silverstripe
PHP is latest version

mysite/_config.php:

<?php

global $project;
$project = 'mysite';

global $database;
$database = 'wwwmack_mackie';

global $databaseConfig;
$databaseConfig = array(
   "type" => "MySQLDatabase",
   "server" => "localhost",
   "username" => "wwwmack_mackie",
   "password" => "***redacted***",
   "database" => "wwwmack_mackie",
);

// setup so I can fix build of database
Director::set_environment_type('dev');

// Sites running on the following servers will be
// run in development mode. See
// http://doc.silverstripe.com/doku.php?id=devmode
// for a description of what dev mode does.
Director::set_dev_servers(array(
   'localhost',
   '127.0.0.1',
));

require_once('conf/ConfigureFromEnv.php');

MySQLDatabase::set_connection_charset('utf8');

// This line set's the current theme. More themes can be
// downloaded from http://www.silverstripe.org/themes/
SSViewer::set_theme('mackie2');

// enable nested URLs for this site (e.g. page/sub-page/)
//SiteTree::enable_nested_urls();

.htaccess file:

### SILVERSTRIPE START ###
<Files *.ss>
   Order deny,allow
   Deny from all
   Allow from 127.0.0.1
</Files>

<Files web.config>
   Order deny,allow
   Deny from all
</Files>

ErrorDocument 404 /assets/error-404.html
ErrorDocument 500 /assets/error-500.html

<IfModule mod_alias.c>
   RedirectMatch 403 /silverstripe-cache(/|$)
</IfModule>

<IfModule mod_rewrite.c>
   SetEnv HTTP_MOD_REWRITE On
   RewriteEngine On

   RewriteCond %{REQUEST_URI} ^(.*)$
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###

Avatar
swaiba

Forum Moderator, 1805 Posts

12 February 2011 at 12:07am

ok, maybe if you explain what exactly happens when you type in www.yoursite/dev/build it might help give you some suggestions...

Avatar
skwok

Community Member, 2 Posts

12 February 2011 at 4:21am

Duh. Sorry. I'm getting a Page not Found 404 error.

Avatar
Willr

Forum Moderator, 5513 Posts

12 February 2011 at 2:55pm

skwok - perhaps you don't have any rewriting enabled? (mod_rewrite for apache) perhaps try http://test.mackieconsult.com/index.php/dev/build

Avatar
k0diak

Community Member, 2 Posts

16 July 2011 at 8:21pm

Hello everyone.

I am a S_S newbie; and like many of you, in attempting to 'run' my .../dev/build command on my domain; I too would end up with 404 errors.

What the instructions forget to mention (or at least in my circumstances) is that it is to activate the dev build commands, it is not the URL the instructions promote of domain-name.com/dev/build when working with S_S.

The URL I used and found it to work for me ( just added the blog module) is;

http://your-domain-name/index.php/dev/build

Now when I use that VERSION of what intended as /dev/build - I get results.

Give it a try - if adding in the /index.php/ in front of the /dev/build works at your domain - please post after this so others know it works at more than one domain/server.

Thanks - Enjoy S_S everyone!