Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

500 Internal Server Error


Go to End
Reply


11 Posts   4318 Views

Avatar
martimiz

Forum Moderator, 1131 Posts

2 April 2011 at 5:53am

Google 'x-httpd-php5" aborted: read failed' - you'll find this seems to be largely a GoDaddy issue. I've no experience with Godaddy, but lots of people refer to the possibility of disabling fastCGI. One of them:

http://www.phpbb.com/community/viewtopic.php?f=46&t=2111345

It suggests 'changing the file extension settings in the control panel to use PHP5.x instead of PHP5.x-Fast-CGI. ' in some way. Maybe this could point you in the right direction?

Avatar
Briohny

Community Member, 199 Posts

2 April 2011 at 9:31am

Excellent. Thank you. I will give this a try.

Avatar
Briohny

Community Member, 199 Posts

4 April 2011 at 8:09pm

Ok, so I disabled FASTCGI via the GoDaddy control panel (I'd never even enabled it) and this seems to have solved my problem. Not only have the 500 Internal Server Errors stopped happening but my site is loading a hell of a lot faster! Hopefully this is the only thing that was causing my errors and that my problem has finally ended! Thanks Swaiba & Martimiz for your help. :)

Go to Top