Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

installation with Ubuntu 11.04 (natty)


Go to End
Reply


3 Posts   1955 Views

Avatar
sathyashrayan

Community Member, 5 Posts

28 April 2011 at 4:33pm

Hi group,
I have a problem during the installation. It throws error

date.timezone set and valid date.timezone option in php.ini must be set in PHP 5.3.0+

My system details are as follows:

Ubuntu 11.04 (natty)
PHP Version 5.3.5-1ubuntu7
Apache 2.0
mysql 5.1.54

date/time support enabled
"Olson" Timezone Database Version 0.system
Timezone Database internal
Default timezone US/Central

Directive Local Value Master Value
date.default_latitude 31.7667 31.7667
date.default_longitude 35.2333 35.2333
date.sunrise_zenith 90.583333 90.583333
date.sunset_zenith 90.583333 90.583333
date.timezone US/Central US/Central

I did not put a "" in the php ini date.timezone variable .

Any help? I need to pass this for installation and see how it works.

Avatar
Invader_Zim

Community Member, 141 Posts

29 April 2011 at 12:54am

Edited: 29/04/2011 12:56am

Hi sathyashrayan,

have you seen this thread?
Php.net shows a warning if you want to use US/Central for date.timezone.
(see here: http://nz.php.net/manual/en/timezones.others.php)
Maybe pick a another, suitable one from here: http://nz.php.net/manual/en/timezones.america.php

Cheers,
Christian

Avatar
sathyashrayan

Community Member, 5 Posts

30 April 2011 at 12:12am

Thanks for the reply. I got it solved by the following:

date.timezone : Asia/Colombo (without quotes)

I live in south part of India.

Hope this thread could be helpful for others.