Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

File is not a valid upload, 2.4.5


Go to End
Reply


10 Posts   3410 Views

Avatar
Shandast

Community Member, 3 Posts

30 June 2011 at 3:44am

New to SilverStripe, and I have to say a pretty abysmal start.

Out of the box, on fresh install of 2.4.5, I can't even upload a 20kb jpg.

Did a search on the forums, seems to be a whole slew of similar problems dating back as far as 2 years ago.

Could not find one answer that worked.

Yes, assets/uploads folder has the correct permissions.

I have other systems on this same server, Wordpress, Drupal, Concrete all with zero issues uploading files of any type.

Again, pretty abysmal!

Avatar
samueljohn

Community Member, 6 Posts

30 June 2011 at 4:54am

Edited: 30/06/2011 6:32am

Same problem over here. I upgraded to 2.4.5 (from 2.3.7) and I cannot upload files as admin.

Update:

[SOLUTION]: The patch http://open.silverstripe.org/changeset/114471 solved my problem, which showed up as "File is not a valid upload".

Please note that the suggestion by some other user in this forum (http://www.silverstripe.org/general-questions/show/11774?start=48#post302839) did NOT solve my problem but the patch in changeset 114471 did.
However, be careful, the lines stated in the patch are no longer correct for 2.4.5. In my case it was line 250 instead of 260 in the Folder.php and the lines 223 instead of 203 in the file AssetAdmin.php.

Avatar
Shandast

Community Member, 3 Posts

30 June 2011 at 7:14am

Ah, Thank you for pointing to a solution!

This first experience has really soured me on SilverStripe -- as a new user I dread to imagine what other surprises await when such a basic piece of functionality is busted right out of the gate.

Avatar
Shandast

Community Member, 3 Posts

30 June 2011 at 7:17am

Wow, I just noticed the timestamp on that "fix" was 7 months ago! And it's still not rolled out?

Ok, that's enough to alienate me from SilverStripe forever. Nice potential but going to look elsewhere!

Avatar
samueljohn

Community Member, 6 Posts

30 June 2011 at 7:35am

Overall, I am quite impressed by SilverStripe. No other issues than this one of which I can tell you.

Definitely, I could not believe that this path is not already rolled out.

Avatar
cheeks

Community Member, 4 Posts

12 July 2011 at 9:42pm

Edited: 12/07/2011 9:43pm

Tried the Solution:

Using SS 2.45

The patch http://open.silverstripe.org/changeset/114471 solved my problem, which showed up as "File is not a valid upload".

This solution did not work for me

Any other ideas?

Any help greatly appreciated

Avatar
samueljohn

Community Member, 6 Posts

12 July 2011 at 9:46pm

Hmmm...
...are you aware that the lines that have to be changed are shifted a bit, so you cannot apply the patch "blindly"?

Avatar
cheeks

Community Member, 4 Posts

13 July 2011 at 3:47pm

samueljohn

thanks for your help, much appreciated

i checked and sorted out my problem as you recommended. all works fine

thanks again

Go to Top