Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Please choose an authentication method and enter your credentials to access the CMS


Reply

7 Posts   2869 Views

Avatar
arthurdent

7 July 2011 at 7:19pm (Last edited: 7 July 2011 7:29pm), Community Member, 166 Posts

While I see this has cropped up for a number of other users, I'm starting this as a new topic in order to clarify my situation completely:

I have built a new website for a client using the SilverStripe CMS. I have it running fine in my local environment. I have also had it running on two test URLs, both hosted by [url]http://www.net24.co.nz[/url] without incident. Unbeknown to me, my client's IT Contractor booked web hosting with another company, [url]http://www.openhost.co.nz[/url]. So this is where we ended up.

I uploaded the latest copy of the database, uploaded a clean copy of SilverStripe (2.4.5). I completed the upload, adding my theme folder and the code folder from the 'mysite' directory - and the fun started. This was the first SilverStripe install that simply refused to run.

The people at OpenHost were very helpful. They advised me that I needed to file a request for the site to be run in php 'safe mode'. Without this the site simply refused to run (I believe this is due to a 'feature' on their new Linux servers).

I now have the main part of the site up and running. I can access the page content. But HomePage refuses to run. When I try I get a page that simply says:

Home
Generated with the default ContentController.ss template

But wait, there's more... having accessed one of the sites pages, if I click the 'admin' link the page url changes to:

index.php/Security/login?BackURL=%2Findex.php%2Fadmin%2F

WTF? What's with the bit after the question mark. And why is this pages telling me to 'Please choose an authentication method and enter your credentials to access the CMS.' but giving me no fields to enter this information into (and yes, before you ask Page.php does include the $Form parameter). So I can't actually log into the database...

And, oh yes finally, if (out of desperation) I do a index.php/dev/build/ I get:

This page is secured and you need administrator rights to access it. Enter your credentials below and we will send you right along.

Very friendly and also helpful. But, of course, there is no login form?!

Anybody have any idea as to what the hell is going on? What fundamental truth am I missing here?

All helpful suggestions appreciated!!

Avatar
Willr

7 July 2011 at 7:30pm Forum Moderator, 5511 Posts

Generated with the default ContentController.ss template

It will default to the ContentController if no template can be found. You should check to see if your themes folder got uploaded fine, also check the permissions on the folder to make sure that SS can read the file (webserver user needs to be able to read those themes directory).

index.php/Security/login?BackURL=%2Findex.php%2Fadmin%2F WTF? What's with the bit after the question mark.

That bit after the ? is the encoded URL for the return value, %2f is the encoded version of /. So it says after you've logged in, go back to the index.php/admin page.

Can't provide much more idea why the form doesn't appear, haven't tried hosting with openhost.

Avatar
arthurdent

7 July 2011 at 8:10pm Community Member, 166 Posts

Thanks for your prompt response Willr. I've just checked -- all my theme data is uploaded to the server and folder permissions are all set to read/execute... so I don't think that it's a permissions thing.

And as for the form data - don't know. When I do a 'view source' on a served page the form code isn't even there!! I'll keep thinking on it...

And strangely, when I tried running the Blackcandy theme it didn't even load, still kept running my template... ?

Avatar
arthurdent

9 July 2011 at 2:47pm Community Member, 166 Posts

It looks as if it was due to a problem uploading Sapphire to the web server. Eventually I thought it would do no harm to go through the Sapphire directory file - by - file (remember this site is running successfully in the local environment and on two test installations using identical version of SilverStripe). When I did a /dev/build/ my form fields were there. So go figure...

Now my other major headache is the the HomePage is still not showing up:

1. Check mysite/code/HomePage.php OK
2. Check themes/mytheme/templates/HomePage.ss OK
3. Do /dev/build?flush=all OK

Doesn't work. Have I missed anything here?

Oddly enough, in the CMS I don't seem to be able to get the dropdown list page type for the home pages to 'stick' to HomePage - it keeps trying to change it to something else (I was just working on a contact form and it asked me if I wanted change to that page type - long story - that one isn't working properly either. Just weird? Or something more sinister?

Anybody got any helpful suggestions?

Avatar
arthurdent

9 July 2011 at 2:56pm Community Member, 166 Posts

So I just deleted the page completely and re-created it. And now it works. Go figure?!

(I guess something in the Database simply got screwed?)

Avatar
wildflower1975

8 August 2011 at 3:50pm Community Member, 59 Posts

I've just had tis problem too/as well.

All of my permissions were correct but:

I gzipped my theme directory incorrectly before I sftp'ed it to my server.

So when I gunzipped it, all of my files (.png, .gif, .css, .ss) had .gz on the end of them - So Silverstripe couldn't read/find any templates to use so used the default one.

HTH

Avatar
lxer

16 August 2013 at 11:51pm Community Member, 16 Posts

a bit late probably, but perhaps usefull for other people looking for this.

Make sure you have the $Form in your Page.ss file. So you probably end up with something like this:

$Content
$Form
$ContactForm
$PageComments