Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Instal Network Solutions


Reply


2 Posts   714 Views

Avatar
XannaX

Community Member, 6 Posts

19 August 2011 at 2:51pm

I'm going insane!! I cant get friendly urls working. Ive tried editing the .htaccess file, php.ini, etc. This is my only issue. I have tried all the hacks? Nothing works. Does anyone have experience dealing with Network Solutions?

Avatar
XannaX

Community Member, 6 Posts

20 August 2011 at 1:38pm

SOLVED: mod_rewrite Issues

ISSUE: During installation the .htaccess file gets written to the "wrong" directory. It puts the .htaccess file in the SilverStripe-v directory after unpacking and doing a browser install. Remove the .htaccess file from the SilverStripe-v dir and place it in the root, problem solved. This is the correct code for .htaccess:

### SILVERSTRIPE START ###
<Files *.ss>
   Order deny,allow
   Deny from all
   Allow from 127.0.0.1
</Files>

<Files web.config>
   Order deny,allow
   Deny from all
</Files>

ErrorDocument 404 /assets/error-404.html
ErrorDocument 500 /assets/error-500.html

<IfModule mod_alias.c>
   RedirectMatch 403 /silverstripe-cache(/|$)
</IfModule>

<IfModule mod_rewrite.c>
   SetEnv HTTP_MOD_REWRITE On
   RewriteEngine On
   RewriteBase /

   RewriteCond %{REQUEST_URI} ^(.*)$
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###