Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Connection Reset on login screen


Reply

691 Views

Avatar
shizny

14 January 2012 at 6:42pm (Last edited: 14 January 2012 6:50pm), Community Member, 1 Post

Hello,

I'm trying to get SS going on my MAMP setup (2.0) . I keep getting a "Connection Reset" error when I try to go to the index page of my SS site in Firefox. In Chrome I get a "No Data" message. If I go into my _confg.php file in /main of my SS project and remove my testing url from the db switch statement (that connects to the appropriate db for me) I can get the login page to show me the error message No DB selected for hostname. So, I can't tell if my problem is from MAMP or from silverstripe. Has anybody else run into an error like this? Also, in the apache error logs I'm getting stuff like this.

[Fri Jan 13 23:18:53 2012] [notice] child pid 13081 exit signal Abort trap (6)
httpd(13082) malloc: *** error for object 0x10b4c2630: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
[Fri Jan 13 23:25:40 2012] [notice] child pid 13082 exit signal Abort trap (6)

my conf/apache/http.conf file has the following virtual host info in it

NameVirtualHost *:80

<VirtualHost *:80>
ServerName test.mvretail.josh
ServerAlias test.mvretail.josh
DocumentRoot "/Applications/MAMP/htdocs/test.mvretail.com"
<Directory "/Applications/MAMP/htdocs/test.mvretail.com/">
Options All Indexes
</Directory>
</VirtualHost>

my host file looks like this

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
127.0.0.1 test.mvretail.josh
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost