Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Install problem with silverstripe 3.0.0 beta: Blank install page


Reply


4 Posts   728 Views

Avatar
crowdly

Community Member, 1 Post

3 April 2012 at 2:21pm

Edited: 03/04/2012 2:23pm

Hello together,

I have a 2.x installation of silverstripe running.
As it looks really very promising, I wanted to try out the new 3.0.0 beta.
I downloaded the .tar.gz, copied it to a folder, set up a database etc.
But already the first step goes wrong. With my 2.x with exactly the same apache configuration in this folder it worked.
With the 3.0.0 just copied into this folder I only see a blank page at domain.de/install.php and at domain.de . No error message at all. Nothing.
I looked up the apache server error log file. It contains the following line for every call of these pages:

PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM, expecting ',' or ')' in /srv/www/vhosts/domain.de/subdomains/ss/httpdocs/sapphire/core/Object.php on line 280
PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM, expecting ',' or ')' in /srv/www/vhosts/domain.de/subdomains/ss/httpdocs/sapphire/core/Object.php on line 280

I am not very experienced with problems like that with silverstripe. Up to now it was well running. Please, if anyone has suggestions: I would appreciate any idea!

Best regards

Andrew

Avatar
Willr

Forum Moderator, 5513 Posts

5 April 2012 at 11:00pm

Try the latest master download from git. This was a bug with the 3.0.0 release archive that was fixed pretty quick (I believe).

Avatar
HanSolo

Community Member, 83 Posts

13 April 2012 at 12:31am

Hi Willr where do I find the latest relase have been to git but cant find anything that has to do with SS 3

Avatar
Willr

Forum Moderator, 5513 Posts

13 April 2012 at 5:46pm

You'll need to download the framework and cms modules, replace those folders in your install just as you do for any other upgrade.

https://github.com/silverstripe/sapphire/tarball/master
https://github.com/silverstripe/silverstripe-cms/tarball/master