Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[SOLVED] New installation (wrongly?) says no gd2 or iconv support


Reply

656 Views

Avatar
mgushee

8 May 2012 at 12:13am (Last edited: 8 May 2012 2:24am), Community Member, 1 Post

Hi, folks. I have just taken on the job of maintaining the website for an organization I belong to, and I am advocating that we use a CMS, mainly to facilitate content editing by non-technical people, and SilverStripe looks like a very good choice. As a first step, I'm trying to set up SilverStripe on my own computer. I will note that the issue I'm seeing should not happen on the production server, because the site is hosted on GoDaddy.com, which has SilverStripe preinstalled. Nonetheless, I feel it is a good idea to get to know the product on my own box before I touch the production environment.

Anyway, the welcome page claims I do not have GD2 or iconv support. But as far as I can see, this is not true. I am running Arch Linux (w/ full system upgrade 3 days ago) and php 5.3.12. I also have gd 2.0.36RC1 installed, and have installed php-gd 5.3.12 (which is a separate package under Arch Linux). Furthermore, phpinfo() reports "--with-gd=shared" and "--with-iconv=shared." So ... can anyone tell me what the error message really means?

UPDATE: Oops, sorry! It has been a long time since I've used PHP. I just needed to enable those modules in my php.ini. Thanks to those who were going to help ;-)