Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Uploaded localhost files cant open on my webserver


Reply


6 Posts   1527 Views

Avatar
webdeb

Community Member, 22 Posts

26 May 2012 at 2:01pm

Edited: 05/06/2012 2:26pm

I had successfully installed silverstripe and run it on my windows based wamp localhost. I was able to install a basic version of silverstripe via my cpanel softaculous, but as soon as I uploaded extensions via ftp to my webserver (that uses Linux)then my website would not open. the url said-
Not Found:
The requested URL /silverstripe/sapphire/main.php was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I asked in this forum last week: can someone please advise me if I should uninstall silverstripe from my webserver and start again, as need to know next step...
I also wondered if my control panel, which auto installed to a folder called "stripe" caused any conflict too - especially if local host files use the folder name silverstripe?

Well I waited more than a week but no-one replied to this question, so I looked up someone on the silverstripe network and emailed them for a possible solution:

Richard very kindly suggested these steps for me, so in case anyone else has a similar problem, you could try this. I havent done it yet but hopefully it will work: (thank you Richard)

Because of the not found error, and the fact that I had used an auto install cpanel version of silverstripe on my webserver, I should first of all uninstall that and start again by downloading a linux version of silverstripe, and then upload that latest version/install that basic system on my webserver, creating a clean slate. Then, I should migrate all the silverstripe folders to top root level of website public html folder, (because my webserver had all of silverstripe files in a subfolder called stripe). There is a youtube video showing how to do this. (great video) Then next step is to edit and re-upload the htaccess file relating to this line of code: RewriteBase /silverstripe - so just remove the /silverstripe bit, (when it is moved to top level folder).. Then lastly I should be able to ftp transfer the extensions folders which should not interfere with the visibility of the site.
Alas, I did the above, but got this:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@rarotonga-island-accommodation.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Looks like I need the services of a programmer, is there anyone in the whole world, that is willing to help me? I can give them access to do the job and would even pay for your time if you want to be paid?

Attached Files
Avatar
webdeb

Community Member, 22 Posts

5 June 2012 at 2:17pm

well I tried those steps and they didnt work. I still have the localhost version working on my pc but I cannot upload it to a website. This is getting too hard and complicated, becoming impossible unless you are already a highly advanced programmer. I have only been doing html websites for 12 years and I cannot make head nor tail of all the errors that keep coming up when trying to install on a webserver. Impossible! I shall have to abandon silverstripe because there is no support, and help, your forum is not really providing answers nor assistance.

Avatar
cuSSter

Community Member, 56 Posts

5 June 2012 at 10:06pm

Does your domain name point to the correct web directory in your web hosting?

Avatar
webdeb

Community Member, 22 Posts

5 June 2012 at 11:11pm

Yes, thats a good question. thanks for asking. Yes the domain points to my nameservers, and the domain name is picking up fine as its pointing to the correct account/public html directory, I set it up myself. I did get the first default silverstripe working fine in that directory, and you used to be able to clearly see to navigate to the stripe folder from the browser url, but after uploading extensions, it stopped working so I deleted all files in that folder in order to start over again. Then I uploaded and installed another one and that didnt work either, so I deleted everything again. Is this something to do with too many databases installed and not now being used? when the 2nd install of stripe didnt work, I deleted everything and I tried another cpanel install, since the very first one had worked. With this third attempt to install, I have 3 failed attempts and 3 databases sitting around, is that going to cause a problem? I cant help but think, that my localhost install is all geared to link to the first database which is now deleted. How do I know, if the new webserver install, can link up with my localhost version correctly? Anyway, right now, the webdirectory is empty so nothing to see...Maybe someone is willing to try and install a new one properly for me, I will give all my ftp details etc? Perhaps also, I should delete the whole account and start another one on my whm?

Avatar
cuSSter

Community Member, 56 Posts

5 June 2012 at 11:29pm

Edited: 05/06/2012 11:30pm

I haven't encountered any problem with deleting and installing silverstripe a couple of times on the same domain back then. The databases wouldn't do much harm aside from just sitting around without any purpose and eating a couple of megabytes off your hosting space. I can try to install it for you if you like. Just shoot me an email. It's custerfrianeza@yahoo.com

Avatar
webdeb

Community Member, 22 Posts

6 June 2012 at 12:30am

thanx I shall now eat my words about not getting assistance, that was wrong! I am posting for all the world to see! thanks for offering the help! :-)