Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Release Candidate - Friendly URLs error


Reply

5 Posts   697 Views

Avatar
kylehudson00

24 June 2012 at 8:10pm Community Member, 22 Posts

Hi All,

Just tried installing an instance of SilverStripe 3 release candidate on my local webserver. I have several 2.4.x installations running perfectly, with friendly URLs working. All requirements passed on the install screen (including URL rewriting), however during the installation I get the following error:

"Checking that friendly URLs work...
Friendly URLs are not working. This is most likely because a rewrite module isn't configured correctly on your site. You may need to get your web host or server administrator to do this for you:
- mod_rewrite or other rewrite module is enabled on your web server
- AllowOverride All is set for the directory where SilverStripe is installed"

AFAIK, mod_rewrite is enabled, because my other SS sites are still running fine, and my server did pass the requirements check. Any thoughts as to what could be causing this? Re: the second option, "AllowOverride All", could someone explain what this is and how to enable it?

Many thanks.

Avatar
kylehudson00

27 June 2012 at 1:54am Community Member, 22 Posts

Well, I reinstalled MAMP, and tried with Silverstripe 3 RC2. Same thing. Any thoughts?

Avatar
Guy Van Bael

27 June 2012 at 2:14am Community Member, 34 Posts

Hi,

Until yesterdag, a lot of people experienced the same problems.
Get the latest builds (cms, framework, installer) from github and installation will succeed.

https://github.com/silverstripe

Avatar
kylehudson00

27 June 2012 at 1:10pm Community Member, 22 Posts

Thanks very much for the reply!!! Is the "Master" branch the latest? If so, unfortunately I'm still getting the same problem. I might just try again in a few days.

Avatar
kylehudson00

27 June 2012 at 2:30pm Community Member, 22 Posts

Fixed here: https://github.com/silverstripe/sapphire/commit/6ef4f9ad3fafb3ecce93bf6f49270cf6960ce597

Now working fine. :)