Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

installing silverstripe 3.0 error


Reply


25 Posts   8875 Views

Avatar
bod

Community Member, 72 Posts

26 September 2012 at 12:00pm

Same as Liam,

OS X 10.8.2 using both UnArchiver and Archive Utility...
Dev Environment: Mamp Pro.

Avatar
steve_nyhof

Community Member, 224 Posts

26 September 2012 at 12:03pm

Downloaded and unzipped on Windows 7 Home Premium
Service Pack 1
Uploaded with Filezilla to cPanel / Linux

Avatar
Sean

Forum Moderator, 922 Posts

26 September 2012 at 3:57pm

Hi everyone,

There's an alternative to the .tar.gz download, which is just in zip format:

[url]http://www.silverstripe.org/assets/releases/SilverStripe-cms-v3.0.2.zip[/url]

Could any of you check to see if this one has the same problem? (unless you've already tried)

Cheers,
Sean

Avatar
Liam

Community Member, 470 Posts

27 September 2012 at 1:29am

Yes that appears to have full file extensions.

Avatar
bod

Community Member, 72 Posts

27 September 2012 at 1:38am

Yep, same here, that has the complete extensions.

Avatar
Sean

Forum Moderator, 922 Posts

27 September 2012 at 9:37am

Could you explain exactly your process for uploading and software? I still can't replicate it, even downloading the .tar.gz on Mac OS X 10.8.2, zipping up framework, then FTP'ing that zip to a server, then unpacking it. I've also tried uploading the framework folder directly over FTP without compressing it first, and there were no problems on the destination server with missing files or broken extensions. It's a bit of a mystery.

Tried it on Windows XP and Windows 7 as well with no problems, but I used 7zip to extract the .tar.gz. I guess that *could* have different results depending on the utility you're using to extract the file.

Thanks,
Sean

Avatar
bod

Community Member, 72 Posts

27 September 2012 at 8:43pm

Hi Sean,

Simply downloaded the tar.gz to my local www folder for the project, double clicked it/unzipped it on my Mac, set up and pointed Mamp Pro at the folder and start to run the install process via localhost.mysite:8888 using Chrome, each time it comes up with a fatal error on the missing php extension for those third party files which are all unzipped as .ph instead of .php..

Your new .zip you posted works fine however..

HTH.

Avatar
priithansen

Community Member, 25 Posts

29 September 2012 at 3:45am

Indeed I have long had the corrupted unpacking problem on OSX. Both with OSX built in "Archve Utility" and the popular "The Unarchaiver" have the problem.
I have been using utility named "GUI Tar" so far without problems.