Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[SOLVED] SS3 installation error: [Warning] is_readable(): open_basedir restriction in effect


Go to End
Reply


22 Posts   8910 Views

Avatar
_dave

Community Member, 4 Posts

24 November 2012 at 4:49am

Same here, with the difference that my SS install worked fine on bluehost, but produced warnings on another shared hosting server. phpinfo() outputs attached.

SS v3.0.2, UserForms v1.0

Cheers
Dave

Attached Files
Avatar
walid

Community Member, 3 Posts

14 August 2013 at 7:58am

Thank you Optic Blaze for this helpful info :-)

Avatar
Liam

Community Member, 470 Posts

1 November 2013 at 7:01am

I'm stuck on some pretty terrible hosting with a certain client project I'm working on and believe I have the same issue.

I can't run 3.1 as the server is using an old version of pcre which throws errors and the link rewriting in tinymce/htmleditorfield won't work.

So I installed 3.0.8 but am getting the same errors as mentioned in this thread, even though it appears to be fixed in an earlier point release.

Obviously if I put the site environment in live mode the errors are suppressed, and after some testing everything appears to work fine including file uploads.

Do I just stomach it and move along as normal or will it break somewhere along the lines and I'm just not seeing it at the moment in my tests? Basically, what exactly will the error effect?

2 errors:

[Warning] is_readable(): open_basedir restriction in effect. File(/usr/bin/pear/Zend/Translate/Adapter/I18nRailsYamlAdapter.php) is not within the allowed path(s): (/var/www/vhosts/clientname/:/tmp/)

[Warning] is_readable(): open_basedir restriction in effect. File(/usr/share/pear/Zend/Translate/Adapter/I18nRailsYamlAdapter.php) is not within the allowed path(s): (/var/www/vhosts/clientname/:/tmp/)

Searches both /usr/bin/.... and /usr/share/....

Avatar
Optic Blaze

Community Member, 165 Posts

1 November 2013 at 9:02am

Edited: 01/11/2013 9:02am

Hi there,

The only thing i have found that has worked is the following. I am successfully running 3.1.1 on a server that gives me the same error as you mentioned:

Go to: framework/thirdparty/Zend/Loader.php
at about line 190 you will find this foreach statement:

foreach (self::explodeIncludePath() as $path) {
if ($path == '.') {
if (is_readable($filename)) {
return true;
}
continue;
}
/*   COMMENT THIS OUT      
$file = $path . '/' . $filename;
if (is_readable($file)) {
return true;
}
*/
}

Hope it helps

Avatar
Liam

Community Member, 470 Posts

2 November 2013 at 2:13am

That seems to fix it on 3.0.8 as well. I guess I'll just move ahead and hope for the best. The site is just a small 5 page brochure site, with no translations, so I hope I'll be alright.

Thanks for the help.

Avatar
s_a_m_y

Community Member, 25 Posts

7 January 2014 at 8:38am

Had the same issue installing 3.1.2 on a shared host with not php.ini-access. Commenting out the mentioned lines also did it for me. Thanks!

Go to Top