Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installation out of memory issues


Reply

3 Posts   721 Views

Avatar
Robin Marlow

9 July 2012 at 9:11am Community Member, 2 Posts

Hello,
Trying to install v3 on a 1&1 host I've been stumped by out of memory issues.

Installing gives me:

Fatal error: Out of memory (allocated 11534336) (tried to allocate 40 bytes) in /[snip]/htdocs/SilverStripe-v3.0.0/framework/core/manifest/ClassManifest.php on line 333

and a _config is created but no database.
So it won't let me reconfig without deleting _config

If I try to open index.php I get the same error:
Fatal error: Out of memory (allocated 11534336) (tried to allocate 262144 bytes) in /[snip]/htdocs/SilverStripe-v3.0.0/framework/core/manifest/ClassManifest.php on line 333

I can't access my php error logs as the host doesn't make them available.
Is there a debugging mode I can turn on?

I tried increasing the memory to 128M (memory_limit = 128M) & this is reported by phpinfo();
(other output here http://pastebin.com/QicD60ux)

v2.3.7 is still working beautifully.

How can I troubleshoot this?

Thanks,

Robin Marlow

Avatar
Robin Marlow

10 July 2012 at 9:49pm Community Member, 2 Posts

Figured it out, my hosting package with 1&1 only gave me 30Mb memory. Even though if set it would report more.
I guess the info from phpinfo is not something that can be relied on & you may have to ask your host.

Fortunately their current packages are half the price & have over twice the memory so "downgrading" has given me a significant upgrade.

All installed and working beautifully now, thanks SilverStripe for saving me money!

Robin

Avatar
Optic Blaze

10 July 2012 at 9:56pm (Last edited: 10 July 2012 9:56pm), Community Member, 162 Posts

Don't know if you have SS in development mode. To do that put the following code in your _config.php file:

//Set development mode //
Director::set_environment_type("dev");