Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installing SS3 on local machine


Reply


7 Posts   996 Views

Avatar
nickm

Community Member, 4 Posts

12 July 2012 at 8:55pm

Hi - I looked at SS a few years ago - time for another look. :-)

I downloaded and installed on my local Win 7 PC using option 3 on the download page.
I can get into the CMS ok when doing it - but wondered why the getting started documentation didn't match. Then I realised that the documentation was referring to Version 3, not the 2.4.7 version I had installed using option 3.

So might as well start out using version 3...

I extracted SilverStripe-cms-v3.0.0 download to a folder in MyWebSites, rename it to silverstripecms.
I have then discovered that I need to go to files in webmatrix, right click install.php and launch in browser.
Install page warned about php missing fileinfo support.

Now on installation page got...
Building database schema...
Warning: require_once(zend_translate_railsyaml/library/Translate/Adapter/RailsYAML.php): failed to open stream: No such file or directory in C:\Users\Nick_2\Documents\My Web Sites\silverstripethree\framework\i18n\i18nRailsYamlAdapter.php on line 3 Fatal error: require_once(): Failed opening required 'zend_translate_railsyaml/library/Translate/Adapter/RailsYAML.php' (include_path='C:\Users\Nick_2\Documents\My Web Sites\silverstripethree/framework;C:\Users\Nick_2\Documents\My Web Sites\silverstripethree/framework/parsers;C:\Users\Nick_2\Documents\My Web Sites\silverstripethree/framework/thirdparty;.;C:\php\pear') in C:\Users\Nick_2\Documents\My Web Sites\silverstripethree\framework\i18n\i18nRailsYamlAdapter.php on line 3

Any suggestions?

Cheers
Nick

Avatar
rturja

Community Member, 4 Posts

12 July 2012 at 10:31pm

Check that files in C:\Users\Nick_2\Documents\My Web Sites\silverstripethree\framework\i18n\ have .php, not .ph ending. I reckon there was earlier people posting about the same issue?

-Reko

Avatar
nickm

Community Member, 4 Posts

12 July 2012 at 10:50pm

Hi Reko,
Checked all 6 files there are .php.
I checked some forum posts in upgrade and install...didn't find anything helpful.

RailsYAML.php does not exist (I searched all the files...)

Cheers
Nick

Avatar
kinglozzer

Community Member, 151 Posts

12 July 2012 at 11:55pm

Edited: 12/07/2012 11:56pm

I think I had a similar problem, try installing again and setting the language back to English (US) (if you changed it that is). That fixed it for me when it happened to me.

No idea what caused it though as installs since then have been fine

Hope this helps

Avatar
nickm

Community Member, 4 Posts

14 July 2012 at 1:05pm

Hi
Hadn't changed the default language from US. Tried reinstalling using the default template as well. Still no luck.

Nick

Avatar
MarcusDalgren

Community Member, 288 Posts

14 July 2012 at 1:27pm

Check if you have the zend_translate_railsyaml folder in framework\thirdparty.
If you don't then you're missing files from the tar.gz. Either download it again or try unpacking the one you downloaded again.

Avatar
nickm

Community Member, 4 Posts

14 July 2012 at 5:16pm

Hi
the zend_translate_railsyaml folder in framework\thirdparty folder did exist, however the files were .ph instead of .php.
So I renamed them all to .php and an xml file was .xm as well. Now it works thanks.

Cheers
Nick