Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Can't save pages/changes in CMS


Reply


4 Posts   844 Views

Avatar
DonM

Community Member, 8 Posts

30 July 2012 at 12:44pm

Hello, having installed Silverstripe yesterday the installation seemed to work ok (except for perhaps not showing the final page where I could delete the install.php file). However now when I try to make the simplest modifications to the Home page and save it, it won't save. No matter whether I select the "Save Draft" or "Save & Publish" buttons they have a circular arrow that just keeps spinning around indefinitely. If I try to move to another page I get a message saying the page hasn't been saved. If I select OK the changes aren't saved so I'm stuck with the basic Silverstripe CMS pages that can't be edited.

Can someone please explain why the CMS won't save any changes?

Regards Don

Avatar
saulegoode

Community Member, 1 Post

1 August 2012 at 8:52pm

I second this, I have found there a numerous files in this build with extension names shortened which cant be found by the system ie; there are .png files required by the css which have only got .pn and JS file links which only have .j

I amended a few but still getting the js error " has no method 'getPageUrl' " in the leftandmain.js file.

Hope this helps someone resolve the issue as I cant wait to get started on it :)

Avatar
DonM

Community Member, 8 Posts

1 August 2012 at 10:41pm

Thanks saulegoode.

I had previously changed approximately 10 php files that didn't have the "p" on the end, which got me through the installation process. And now having changed approximately 30 files that had the extension ".j" rather than ".js" and about 20 ".png" files that were missing the "g" it appears that the problem is corrected as I can save files.

Much appreciated saulegoode.

Regards Don

Avatar
DonM

Community Member, 8 Posts

20 August 2012 at 8:48am

Hello

Having had these issues some weeks ago, I again incurred them when I tried to install SilverStripe Version 3.0.1 on my website. My webhost (GoDaddy) had version 3.0.1 to download and install but again with the files with incomplete extensions. The work around I found was to rename all files locally that (i believe) had the wrong extension and upload them to my site. This seems to have worked so I'm passing on the list of files so that it hopefully helps someone else and the development team. Please see attached a list of files in which I changed the extension.

Regards DonM