Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

I couldn't find a database server on 'localhost': Access denied for user 'root'@'localhost' (using password: NO)


Reply


3 Posts   4053 Views

Avatar
tmedtcom

Community Member, 2 Posts

14 September 2012 at 11:30pm

hello, I'm stuck at step installation database configuration, it shows me this message:
I couldn't find a database server on 'localhost': Access denied for user 'root'@'localhost' (using password: NO)
you have an idea?

Attached Files
Avatar
Optic Blaze

Community Member, 165 Posts

21 September 2012 at 9:49am

Hi there,

It sounds like 1 of 2 problems

1) The installer is not picking up a database i,e MYSQL. Did you use WAMP to set up your Apache, Php and MYSQL? It could be that you have stopped the MYSQL service, so PHP is working as well as Apache, but it cant pick up a MYSQL database

2) Sometimes when you get the 'Access denied for user 'root'@'localhost' (using password: NO) ' error it means that you are attempting to access MYSQL with a password, but that MYSQL has no password on record for user 'root'. In that case do the silverstripe installation without filling in a password for the Database, or else set a Database password using phpMyAdmin

Let me know if it helps

Avatar
WayneRiesterer

Community Member, 1 Post

14 September 2013 at 9:58pm

Edited: 14/09/2013 9:59pm

One way of correcting the problems here can be done as follows...

1. Open up phpmyadmin by navigating to localhost/phpmyadmin (be sure to include the port number if a non-standard installation has been used for Apache. If a different port is used, then you could put it as localhost:8082/phpmyadmin [or whatever port number is applicable besides 8082])

If that doesn't work, then either MySQL, Apache or both may not be running.

If this is the case, then in:

- Windows: start WAMP and check that both services are running (with a healthy green icon). If not, then try and tackle this problem first.

- Linux: use
sudo service apache start (or apache2, whatever the case may be)
sudo service mysql start

In Linux, if this brings up errors, then follow that up with further searches on the web.

Navigate back to phpmyadmin as in Step 1.

2. Log into phpmyadmin using:

Username = root
Password = [nothing] or whatever password you set

For the database, it's probably not a good idea to set up Silverstripe with the root account. It may be a better option to set up a specific database admin account for each site.

3. Check the "Users" records to see if your username (the one you're using to configure Silverstripe) is there.

4. Ensure that a database with the correct name has been created in MySQL by clicking on the Databases tab.

5. Check the permissions for the user account and change as necessary.

6. Ensure that the correct username and password are entered into the Silverstripe installation page.

7. Ensure that the correct database name has been entered into the Silverstripe installation page.

Recheck the Silverstripe installation status by clicking the relevant button (can't remember what text is on it - it will be obvious though).

There may be other problems associated with file access permissions, mod_enable and time zone configurations.

If that is the case, then there is plenty of stuff on the web for correcting these issues. Just copy and paste the error text into your search engine and it should bring up specific fixes for Silverstripe.

In the case of mod_enable, there are other more general posts that work fine.

Even though this is an old post, I thought that I would still put something in here to help people who may stumble across it sometime long after.

Best of luck - Wayne Riesterer