Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installing problems


Reply


4 Posts   620 Views

Avatar
LordMeuchelmord

Community Member, 2 Posts

30 October 2012 at 10:29pm

Warning: require_once(Zend/Log.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/web7/html/home/framework/dev/ZendLog.php on line 2

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Log.php' (include_path='.:/var/www/web7/html/home/cms/thirdparty/') in /var/www/web7/html/home/framework/dev/ZendLog.php on line 2

I habe no Idea

Avatar
Sean

Forum Moderator, 922 Posts

31 October 2012 at 9:58am

Seems to be something wrong with the include path, as the error states there is only include_path='.:/var/www/web7/html/home/cms/thirdparty/', the framework path appears to be missing.

If you search for set_include_path($includePath); in framework/core/Core.php and add var_dump($includePath); just above that, what does it output when you try the install again?

Sean

Avatar
LordMeuchelmord

Community Member, 2 Posts

3 November 2012 at 10:54am

This:

"/var/www/web7/html/home/framework:/var/www/web7/html/home/framework/parsers:/var/www/web7/html/home/framework/thirdparty:.:/var/www/web7/html/home/cms/thirdparty/"
Warning: require_once(Zend/Log.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/web7/html/home/framework/dev/ZendLog.php on line 2

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Log.php' (include_path='.:/var/www/web7/html/home/cms/thirdparty/') in /var/www/web7/html/home/framework/dev/ZendLog.php on line 2

Avatar
Sean

Forum Moderator, 922 Posts

6 November 2012 at 1:10pm

And if you change var_dump($includePath) to var_dump(get_include_path()) what is showing?

Might be that for some reason, PHP won't let you change the include path based on your hosting environment.