Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Error permission


Reply


4 Posts   973 Views

Avatar
Steph47

Community Member, 2 Posts

9 November 2012 at 2:54am

Hello to the community. I hope you can help me or give me solutions.

Today I modify the .htaccess to manage the browser cache and improve performance of the site but it crashed the site. I put the backup of .htaccess but the error persists.
Here is the error displayed :

Warning: scandir(/var/www/clients/client9/web40/web) [function.scandir]: failed to open dir: Permission denied in /var/www/clients/client9/web40/web/sapphire/core/ManifestBuilder.php on line 196

Warning: scandir() [function.scandir]: (errno 13): Permission denied in /var/www/clients/client9/web40/web/sapphire/core/ManifestBuilder.php on line 196

Warning: Invalid argument supplied for foreach() in /var/www/clients/client9/web40/web/sapphire/core/ManifestBuilder.php on line 197

Warning: scandir(/var/www/clients/client9/web40/web) [function.scandir]: failed to open dir: Permission denied in /var/www/clients/client9/web40/web/sapphire/core/ManifestBuilder.php on line 225

Warning: scandir() [function.scandir]: (errno 13): Permission denied in /var/www/clients/client9/web40/web/sapphire/core/ManifestBuilder.php on line 225

Warning: Invalid argument supplied for foreach() in /var/www/clients/client9/web40/web/sapphire/core/ManifestBuilder.php on line 226

Notice: Undefined index: file in /var/www/clients/client9/web40/web/sapphire/core/ManifestBuilder.php on line 265

Warning: $project isn't set in /var/www/clients/client9/web40/web/sapphire/core/ManifestBuilder.php on line 269

Notice: Undefined index: require_once in /var/www/clients/client9/web40/web/sapphire/core/ManifestBuilder.php on line 137

Warning: Invalid argument supplied for foreach() in /var/www/clients/client9/web40/web/sapphire/core/ManifestBuilder.php on line 137

Fatal error: Class 'SS_Log' not found in /var/www/clients/client9/web40/web/sapphire/dev/Debug.php on line 245

someone has an idea?

Thank you in advance

Avatar
Juanitou

Community Member, 323 Posts

9 November 2012 at 5:18am

Hi!

Have you tried flushing the cache (/dev/build?flush=all) or removing the silverstripe-cache folder?

Hope it helps,
Juan

Avatar
Steph47

Community Member, 2 Posts

9 November 2012 at 9:10pm

I tried, without success.

As the problem is triggered after handling.htaccess, I wonder if my file is correct. Here it is:

### SILVERSTRIPE START ###
#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

<Files *.ss>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Files>

<Files web.config>
Order deny,allow
Deny from all
</Files>

ErrorDocument 404 /assets/error-404.html
ErrorDocument 500 /assets/error-500.html

<IfModule mod_alias.c>
RedirectMatch 403 /silverstripe-cache(/|$)
</IfModule>

<IfModule mod_rewrite.c>
SetEnv APPLICATION_ENV development
Options -MultiViews
RewriteEngine ON
RewriteBase /

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

RewriteCond %{THE_REQUEST} ^(GET|POST|HEAD)\ (/.*)?/sapphire/main.php?url=%1&%
RewriteRule ^(.*)sapphire/main.php?url=%1&%$ /$1 [R=301,L]
</IfModule>
### SILVERSTRIPE END ###

RewriteCond %{HTTP_HOST} !^www.mysite.com$
RewriteRule ^(.*) http://www.mysite.com/$1 [QSA,L,R=301]

Avatar
Juanitou

Community Member, 323 Posts

9 November 2012 at 11:16pm

Sorry, I’m not good at .htaccess debugging… Nevertheless, that’s not the standard SilverStripe .htaccess. Have you checked the Apache logs?