Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Composer: Cloning failed using an ssh key


Reply


3 Posts   1956 Views

Avatar
martimiz

Forum Moderator, 1105 Posts

23 November 2012 at 5:04am

Edited: 23/11/2012 5:12am

I used the following command from my Mac/MAMP installation:

composer create-project silverstripe/installer ./www 3.0.x-dev

The resulting message was as follows:

Installing silverstripe/installer (3.0.x-dev 8e074cdfee70c2bff60ae5e8818c344f2a4ce695)
- Installing silverstripe/installer (3.0.x-dev 8e074cd)
Cloning 8e074cdfee70c2bff60ae5e8818c344f2a4ce695

Created project in ./www
Loading composer repositories with package information
Installing dependencies
- Installing composer/installers (dev-master a3d52d8)
Cloning a3d52d8414ec26533a540ebacbc1c20be568c83f

- Installing silverstripe/framework (3.0.x-dev 96acd50)
Cloning 96acd5068129b9098768ee5ab8431fcfa34db9d7

- Installing silverstripe/cms (3.0.x-dev 1529cd1)
Cloning 1529cd153945d8d841e5f85a7752b0b7203c087f
Cloning failed using an ssh key for authentication, enter your GitHub credentials to access private repos
The credentials will be swapped for an OAuth token stored in /Users/martine/.composer/config.json, your password will not be stored
To revoke access to this token you can visit https://github.com/settings/applications
Username:

As I'm new to Composer, can anyone tell me what happened to make cloning the CMS fail, while framework seemed to go OK, and why entering my Github credentials is necessary to get the cms to clone?

Thanks, Martine

Avatar
martimiz

Forum Moderator, 1105 Posts

23 November 2012 at 6:53am

Edited: 23/11/2012 6:54am

Just to elaborate: using the example version from the silverstripe docs everything goes smoothly:

composer create-project silverstripe/installer ./wwwtest 3.0.2.1

Just trying to get 3.0.x-dev fails on the cms only:

composer create-project silverstripe/installer ./www 3.0.x-dev

From my Mac I could get it by using git credentials (why?), from nix I get 'invalid credentials' and that's it :(

Avatar
martimiz

Forum Moderator, 1105 Posts

24 November 2012 at 12:55am

OK, I got it!
(Needed to create a ssl key for nix to get to the cms, but that's not really the issue)

[url=http://www.silverstripe.org/installing-silverstripe/show/21447]from this post[/url]:
> If you install from a tag like 3.0.2.1, it'll use the github-generated
> ZIPs by default, for both root and dependencies...

So 3.0.2.1 uses the Zip file, that is fast and can be downloaded without the need for a GitHub account.

3.0.x-dev doesn't use the zipfile (why not) but it reverts to the Canonical url set up for the module in Packagist - much slower. But the issue is that the url is different for sapphire and cms

framework: https://github.com/silverstripe/sapphire
cms: git@github.com:silverstripe/silverstripe-cms.git

While the https:// url can be cloned without the need for a ssh key, the git@... does want the ssh key. What would be the advised canonical?

Martine