Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

ss 3.0.3 installation problem on host server


Reply


2 Posts   545 Views

Avatar
jasonjiang73

Community Member, 2 Posts

7 January 2013 at 11:18pm

hi guys:
i try to install ss 3.0.3 on host server ,i upload a complete new ss to the server through FTP.and when i try to access ,it shows
"Warning: file_get_contents(dev/install/php5-required.html) [function.file-get-contents]: failed to open stream: No such file or directory in /storage/content/06/118406/shelton.ayond.com/public_html/framework/main.php on line 19"

it works perfect on my local server on mamp,and on the host server ,the verson 2.4.9 works,
also i have already set the php version on host server to 5.4 so it should support the new ss3.0.3.

anyone knows what's the problem, ?? thanks a lot

Avatar
Sean

Forum Moderator, 922 Posts

9 January 2013 at 9:48am

Edited: 09/01/2013 9:51am

It would appear a PHP version of less than 5.3.2 is running on the server. SilverStripe 3.x requires at least 5.3.2 on there.

The code in question:

if (version_compare(phpversion(), '5.3.2', '<')) {
   header("HTTP/1.1 500 Server Error");
   echo str_replace('$PHPVersion', phpversion(), file_get_contents("dev/install/php5-required.html"));
   die();
}

It's getting into the if block with version_compare, which indicates the PHP version running on there is less than 5.3.2.

Sean