Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

PHP 5.2.9


Reply


4 Posts   862 Views

Avatar
jrobida999

Community Member, 10 Posts

14 January 2013 at 10:09am

My new hosting provider insisted on PHP 5 support, but they failed to tell me that it was 5.2.9. When I contacted them they stated that the version of cPanel they are running is not compatible with 5.3+ and that none of their servers are running 5.3+ either.

They recommended installing SS anyway to see if it will work.

My question:

Will 5.2.9 be sufficient or whill I have issues when trying to install SS 3.0.3?

Jake

Avatar
Sean

Forum Moderator, 922 Posts

15 January 2013 at 1:29pm

Edited: 15/01/2013 1:30pm

SilverStripe 3.x won't work on PHP 5.2.9, the minimum supported version is 5.3.2.

You will run into issues with methods not working and various PHP 5.3 specific syntax such as anonymous functions.

If you really can't get 5.3 support on your server, you could install SilverStripe 2.4 instead (current version is 2.4.9) which will work on PHP 5.2.

Sean

Avatar
jrobida999

Community Member, 10 Posts

16 January 2013 at 10:57pm

I haven't used SS 2.4.9 at all. I'm new to SS 3.0.3 but I love it. What are the drawbacks of 2.4?

Avatar
Sean

Forum Moderator, 922 Posts

17 January 2013 at 9:42am

Feature development and enhancements for 2.4 have ceased, development has been focused on 3.x instead, so the only updates to 2.4 are security fixes.

Just a note that PHP 5.2 support has been cut off by the PHP team, and this has been in effect for a while now. I would suggest to your host they upgrade to *at least* PHP 5.3.2.

If that's not possible, I would recommend getting a new web host.

Sean