Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

change folder structure


Reply


528 Views

Avatar
nice

Community Member, 1 Post

7 March 2013 at 10:37am

Edited: 07/03/2013 10:38am

Hi,
I am trying to install SS on Aruba. They grant r/w permission to a subfolder of root called /public/.
The hosting is IIS and I tried to copy the installation files as they are. When I run the install.php I get

Does the webserver know where files are stored? The webserver isn't letting me identify where files are stored. (file '\sapphire/dev/install/config-form.html' not found)

mysite/ directory exists? Directory '\mysite' not found. Please make sure you have uploaded the SilverStripe files to your webserver correctly.

sapphire/ directory exists? Directory '\sapphire' not found. Please make sure you have uploaded the SilverStripe files to your webserver correctly.

cms/ directory exists? Directory '\cms' not found. Please make sure you have uploaded the SilverStripe files to your webserver correctly.
Is the web.config file writeable? The webserver user needs to be able to write to this file:
\web.config

Is the mysite/_config.php file writeable? The webserver user needs to be able to write to this file:
\mysite\_config.php

Is the assets/ directory writeable? The webserver user needs to be able to write to this file:
\assets

I how can I put those files/folders under the /root/public/ folder and havr everything work properly.

As test I put all files in the /public/ and run the install.php from the /public/ folder. All errors have gone!!!!
thanks for helping!!!