Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Google Sitemap Decorator errors on my site


Reply


3 Posts   464 Views

Avatar
tonspa

Community Member, 1 Post

5 July 2013 at 12:06am

I host my site on godaddy and for some strange reason after I did a update on there site to the newest sliverstrip I get errors on all the of pages.
Strict Standards: Declaration of GoogleSitemapDecorator::onAfterPublish() should be compatible with that of SiteTreeExtension::onAfterPublish() in /home/content/56/8436256/html/googlesitemaps/code/GoogleSitemapDecorator.php on line 9

I can't even log into the admin part of the site anymore. any ideas?

if there is a answer on here please point me in the right way

Thanks!

Avatar
Nobrainer Web

Community Member, 137 Posts

6 July 2013 at 8:40am

I don't know how to fix it, but try to compare the api docs of the 2 versions of the method onAfterPublish in googleSitemapDecorator.

To login, perhaps just remove the googlesitemaps module for now.

Avatar
Willr

Forum Moderator, 5513 Posts

10 July 2013 at 10:56pm

Make sure you use the correct version of the module for your installation. I recommend using Composer to manage dependancies in 3.0. Sounds like you may need to update your module version.