Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Failed installation: ss 3.1.1 magic_quotes_gpc option


Reply


6 Posts   928 Views

Avatar
pinkp

Community Member, 168 Posts

7 November 2013 at 3:45am

Edited: 07/11/2013 3:48am

Im getting a Fail error on a freshly downloaded SS 3.1.1 using MAMP php 5.3.6
The error is:

magic_quotes_gpc option   magic_quotes_gpc is set to '1' in php.ini.
This should be turned off, as it can cause issues with cookies. More specifically, unserializing data stored in cookies.

Exactly as described here: http://stackoverflow.com/questions/19305421/silverstripe-mamp-pro-get-magic-quotes-gpc

I see its documented as deprecated: "Magic quotes is now deprecated. Will trigger user_error on live sites, as well as an error on new installs"

But how do I set the php.ini file to get around this error....?

I've created my file in the root and the framework to no affect..

php.ini

<?php
magic_quotes_gpc = 0
?>

Avatar
pinkp

Community Member, 168 Posts

9 November 2013 at 8:27am

no one ever replies on this forum....

Avatar
Sean

Forum Moderator, 922 Posts

12 November 2013 at 11:13am

You need to edit the php.ini included in MAMP.

If you check phpinfo() and search for where the php.ini is loaded, that'll show you where to find it.

Sean

Avatar
Nobrainer Web

Community Member, 137 Posts

19 December 2013 at 10:32am

This forum really is slow, try using the irc channel also.

I have untill now just disabled that warning message, which lets the system run just fine.
Hope you solved it by now.

Avatar
Wilky

Community Member, 2 Posts

30 May 2014 at 11:47am

I’ve downloaded and installed Wampserver 2.2E 64bit and Silverstripe 3.0.3 (CMS and Framework) from www.silverstripe.org
I followed the 5 minute tutorial video through the website and after clicking the Install SilverStripe button, when running through installation steps, it comes up with
“Friendly URLs are not working. This is most likely because a rewrite module isn’t configured correctly on your site.”
You may need to get your web host or server administrator to do this for you.
mod_rewrite or other rewrite module is enabled on your web server.
AllowOverride All is set for the directory where SilverStripe is installed

It then skips the part which says “Installation successful” and where it allows you to delete installation files.
Instead it just redirects to the log in process, so I don’t have recognition that it has been installed properly.

When I logged in and click on say home page, it says “Warning: You should remove install.php from this SilverStripe install for security reasons.”
I have since removed install.php manually, restarted the computer and that warning message doesn’t appear anymore.
I was just wondering if someone knows why it skipped the above process I mentioned and how I can get the friendly URLs working?
I’m running Windows 7, 64bit.

I’d appreciate any help with this problem.

Avatar
camfindlay

Forum Moderator, 185 Posts

30 May 2014 at 2:05pm

If you are using Apache 2.4+ you'll need to add/edit the following in the httpd.conf file to get the rewrites to play nice:

<Directory /home/*/public_html>
AllowOverride All
DirectoryIndex disabled
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
</Directory>