Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installing to WAMP


Reply


2 Posts   463 Views

Avatar
amaclenan

Community Member, 1 Post

9 February 2014 at 1:07am

Edited: 09/02/2014 1:16am

I have installed the WAMP stack at it is working correctly but when I try to install Silverstripe, I get the error messages below:

Any ideas?

Thanks.

( ! ) Warning: require_once(C:\wamp\www\silverstripe\framework\control\injector/SilverStripeServiceConfigurationLocator.php): failed to open stream: No such file or directory in C:\wamp\www\silverstripe\framework\control\injector\Injector.php on line 6
Call Stack
#   Time   Memory   Function   Location
1   0.0004   150544   {main}( )   ..\install.php:0
2   0.0008   154040   include( 'C:\wamp\www\silverstripe\framework\dev\install\install.php' )   ..\install.php:13
3   0.0036   409696   include( 'C:\wamp\www\silverstripe\framework\dev\install\install.php5' )   ..\install.php:26
4   0.0541   498584   Installer->install( )   ..\install.php5:277
5   0.5624   543416   require_once( 'C:\wamp\www\silverstripe\framework\core\Core.php' )   ..\install.php5:1396
6   0.6166   1653336   require_once( 'C:\wamp\www\silverstripe\framework\control\injector\Injector.php' )   ..\Core.php:83

( ! ) Fatal error: require_once(): Failed opening required 'C:\wamp\www\silverstripe\framework\control\injector/SilverStripeServiceConfigurationLocator.php' (include_path='.;C:\wamp\www\silverstripe/framework;C:\wamp\www\silverstripe/framework/parsers;C:\wamp\www\silverstripe/framework/thirdparty;.;C:\php\pear') in C:\wamp\www\silverstripe\framework\control\injector\Injector.php on line 6
Call Stack
#   Time   Memory   Function   Location
1   0.0004   150544   {main}( )   ..\install.php:0
2   0.0008   154040   include( 'C:\wamp\www\silverstripe\framework\dev\install\install.php' )   ..\install.php:13
3   0.0036   409696   include( 'C:\wamp\www\silverstripe\framework\dev\install\install.php5' )   ..\install.php:26
4   0.0541   498584   Installer->install( )   ..\install.php5:277
5   0.5624   543416   require_once( 'C:\wamp\www\silverstripe\framework\core\Core.php' )   ..\install.php5:1396
6   0.6166   1653336   require_once( 'C:\wamp\www\silverstripe\framework\control\injector\Injector.php' )   ..\Core.php:83

Avatar
camfindlay

Forum Moderator, 171 Posts

10 February 2014 at 8:52am

Can you provide more information about your setup?

Which version of windows are you on? How did you go about installing? Via download zip or composer?