Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Installed WAMP and Silverstripe and come up with errors - don't know what to do now


Reply

6 Posts   2870 Views

Avatar
Brigham

18 December 2008 at 3:45pm Community Member, 5 Posts

Hi

i have installed according to the video here (http://www.silverstripe.com/assets/screencasts/silverstripe-installation-wamp/index.html) and i get an error:

Warning: file_get_contents(http://localhost:3000/silverstripe-v2.2.3/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. in C:\wamp\www\silverstripe-v2.2.3\rewritetest.php on line 47

Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\silverstripe-v2.2.3\rewritetest.php on line 47
---
don't know what to do now. tried loading it again (localhost:3000/silverstripe-v2.2.3) and then got this error:

Notice: Undefined offset: 0 in C:\wamp\www\silverstripe-v2.2.3\sapphire\core\SSViewer.php on line 151

---

anyone got any suggestions?

Avatar
dttri

18 December 2008 at 7:09pm Community Member, 5 Posts

Hi,

Have you tried:

http://localhost:3000/silverstripe-v2.2.3/?flush=1 to see if it works?

Avatar
Brigham

19 December 2008 at 9:29am Community Member, 5 Posts

hi. thanks dttri for your response - it didn't work. Could this be a Vista thing?

Avatar
Hamish

19 December 2008 at 11:02am Community Member, 712 Posts

Undefined offset in SSViewer - possibly it has not found any of your .SS (template) files - which would indicate a file systems issue.

So yes, could be a vista prob. Unfortunately I don't know squat about Vista, but try modifying permissions for the installation folder and see if you have any luck.

Avatar
Brigham

19 December 2008 at 12:06pm Community Member, 5 Posts

thanks Hamish

i just tried installing it on my net laptop that runs on XP and it worked, just like the video said it would. but it's going to be a humbug to work between two machines. Has anyone else had issues with VISTA?

<five minutes later>

OK, i just tried the permissions thing in VISTA (right clicked on the WAMP folder; clicked on permissions; clicked the Security folder; clicked on me (Users....) and then clicked on Advanced and clicked around so i got Full Control; clicked Apply and of it went!)

i am now happy again!

thanks muchly

Avatar
Hamish

19 December 2008 at 1:28pm Community Member, 712 Posts

Awesome!

Added a note in the wiki [url=http://doc.silverstripe.com/doku.php?id=installation-on-windows]here[/url].