Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Silverstripe not installing on localhost


Reply


2 Posts   1865 Views

Avatar
Donkeli

Community Member, 1 Post

19 December 2008 at 2:56am

I followed the installation video but a tried installation on my computer and it wont install. I have xampp on my computer so I poited to port 3000 and had this error

Warning: file_get_contents(http://localhost:3000/SilverStripe-v2.2.3/InstallerTest/testrewrite) [function.file-get-contents]: failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. in C:\wamp\www\SilverStripe-v2.2.3\rewritetest.php on line 47

Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\SilverStripe-v2.2.3\rewritetest.php on line 47

Someone please help me outta this ordeal

Avatar
Carbon Crayon

Community Member, 598 Posts

20 December 2008 at 6:41am

Edited: 20/12/2008 7:14am

EDIT: Just seen this thread: [url]http://www.silverstripe.org/installing-silverstripe/show/251049[/url] have you tried that?

Hi Donkeli

I had this same problem, I still don't know why but SS just wont accept that modrewrite is working.

Anyway to get around it just up your max_execution_time to 200 and memory_limit to 512 in your php.ini

Your install should then have enough time to get to the mod_rewrite test page on install which will fail and ask if you want to continue anyway, and will then forward you to your newly installed site which should be working just fine :)