Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

mod_rewrite issue on powweb


Reply

2 Posts   1658 Views

Avatar
popkiller

24 December 2008 at 2:48pm Community Member, 1 Post

Hello

I know this is a very common problem, but in 2 days of searching this forum and google, i have not been able to find a clear answer.

I am trying to install silverstripe on my powweb server and have been getting hung up on the mod_rewrite problem.
Powweb does support Silverstripe and even has an instant installer, everything seems to install correctly but when i try to alter the first page it gives me the 'internal server error' notice. i have tried a bunch of variations in the .htaccess file, but nothing has seemed to solve the problem.

currently the .htaccess file shows:

### SILVERSTRIPE START ###
RewriteEngine On
RewriteBase /popv2/

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###

if anyone has experianced this problem before or has any tips, i would greatly appreciate it!
I love the capabilities of silverstripe, but it seems like i may need to explore other options.

thanks a lot!

Avatar
Liam

25 December 2008 at 5:21am Community Member, 470 Posts

Does the admin section work? How do you know this is an .htaccess problem?

I'd suggest checking your log files for a more detailed error message.

The only thing I can think of is if you're running php in cgi mode and have some directories set 777 permissions.